forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-php/PEAR-DB_DataObject: add version 1.11.5.
This version bump was mostly straightforward, but the ebuild was ported to EAPI=6 and its dependencies were cleaned up as well. A simpler pattern was used to replace the existing "sed" invocation. The LICENSE was also updated per the homepage. Gentoo-Bug: 573242 Reported-By: Hanno Böck Package-Manager: portage-2.2.26
- Loading branch information
Showing
2 changed files
with
32 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST DB_DataObject-1.11.3.tgz 81873 SHA256 5fa1ce2d3d2543a5b9e8f825a2c9a409201978b0f6c45da1f9dadfe58ac47d2b SHA512 bf74b99b6d28e8c5074dd9058ad6624ed93cd4578164d71fcf2c70070a81f5bb5dfc46d11d5a1408ad5bac12ac6d36cd47dbe102b16ffbf9c091153e9e400d8f WHIRLPOOL 3189f3238afc0d7087ced6c1b1bd91ecf99b009f03e17e907d68404c7d5e06f6ebeda0d5b3ef7235802fd18062ae330ec974b5121de17078521cec2210a1e0c9 | ||
DIST DB_DataObject-1.11.5.tgz 83878 SHA256 0157d3197c28b33d41c069b7f0ed8d2651fe2377e83a0a7b9f1b7a47a4f31b05 SHA512 bc8c5d0994fba78c6f8137682da87018e7660ceb39f5583aabf424509bf0ab263b8f32f6676821acaf69ed991778ad85f5f3fc156799c0811b2ec39546688bc6 WHIRLPOOL 64e1eea3a33e83d307a5059e7f770fb9e16b0c67ac4feb6962e0f7c2caf102a160645005581c9cf828f0013829fe133a2fe8dc66356039283a3b3908f3cc3472 |
31 changes: 31 additions & 0 deletions
31
dev-php/PEAR-DB_DataObject/PEAR-DB_DataObject-1.11.5.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,31 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
inherit php-pear-r1 | ||
|
||
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86" | ||
|
||
DESCRIPTION="SQL builder and data modeling layer" | ||
LICENSE="PHP-3.01" | ||
SLOT="0" | ||
IUSE="minimal" | ||
|
||
# The MDB2/DB dependencies are listed as "optional," but really, you | ||
# need one or the other. Prefer the newer MDB2 to the deprecated DB. | ||
DEPEND="" | ||
RDEPEND="|| ( dev-php/PEAR-MDB2 dev-php/PEAR-DB ) | ||
dev-php/PEAR-Date | ||
!minimal? ( dev-php/PEAR-Validate )" | ||
|
||
src_prepare() { | ||
# Don't install this batch file -- it winds up in ${EPREFIX}/usr/bin. | ||
# Delete the line that mentions it from package.xml. | ||
sed -e '/DB_DataObject_createTables\.bat/d' \ | ||
-i "${WORKDIR}/package.xml" \ | ||
|| die "failed to remove batch file from package.xml" | ||
|
||
eapply_user | ||
} |