Skip to content

Commit

Permalink
media-sound/jack2: new JACK2 ebuild
Browse files Browse the repository at this point in the history
  • Loading branch information
suhr authored and aballier committed Feb 16, 2016
1 parent ec2f791 commit bc49b19
Show file tree
Hide file tree
Showing 3 changed files with 113 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-sound/jack2/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST jack2-1.9.10.tar.gz 6415555 SHA256 88f1b6601b7c8950e6a2d5940b423a33ee628ae5583da40bdce3d9317d8c600d SHA512 0bee815356e9e572224e7cc484c402f38797d70257c4bc79a47552ae30a25a4600c61f712a73cbbede52cd8cb8dc144c9334e28c10e23354a11b7223ee0bb0ca WHIRLPOOL a7b4e14fb1e0490955a363fe0680558d89f80c3cdf18a840991b636518ecf55d872d91d9024770874b5d28494e2cbadc0f21ce4b73ee7873f62842fb0339b0c5
94 changes: 94 additions & 0 deletions media-sound/jack2/jack2-1.9.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,94 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads(+)"
[[ "${PV}" = "2.9999" ]] && inherit git-r3
inherit eutils python-single-r1 waf-utils multilib-minimal

DESCRIPTION="Jackdmp jack implemention for multi-processor machine"
HOMEPAGE="http://jackaudio.org/"

RESTRICT="mirror"
if [[ "${PV}" = "2.9999" ]]; then
EGIT_REPO_URI="git://github.com/jackaudio/jack2.git"
KEYWORDS=""
else
SRC_URI="https://github.com/jackaudio/jack2/archive/v${PV}.tar.gz -> jack2-${PV}.tar.gz"
KEYWORDS="~amd64 ~ppc ~x86"
fi

LICENSE="GPL-2"
SLOT="2"
IUSE="alsa celt dbus doc opus pam"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"

# FIXME: automagic deps: readline, samplerate, sndfile, celt, opus
# FIXME: even though sndfile is just used for binaries, the check is flawed
# making the build fail if multilib libsndfile is not found.
CDEPEND="media-libs/libsamplerate[${MULTILIB_USEDEP}]
media-libs/libsndfile[${MULTILIB_USEDEP}]
sys-libs/readline:0
${PYTHON_DEPS}
alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
celt? ( media-libs/celt:0[${MULTILIB_USEDEP}] )
dbus? (
dev-libs/expat[${MULTILIB_USEDEP}]
sys-apps/dbus[${MULTILIB_USEDEP}]
)
opus? ( media-libs/opus[custom-modes,${MULTILIB_USEDEP}] )"
DEPEND="!media-sound/jack-audio-connection-kit:0
${CDEPEND}
virtual/pkgconfig
doc? ( app-doc/doxygen )"
RDEPEND="${CDEPEND}
dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
pam? ( sys-auth/realtime-base )"

[[ "${PV}" = "2.9999" ]] || S="${WORKDIR}/jack2-${PV}"

DOCS=( ChangeLog README README_NETJACK2 TODO )

src_unpack() {
if [[ "${PV}" = "2.9999" ]]; then
git-r3_src_unpack
else
default
fi
}

src_prepare() {
default
multilib_copy_sources
}

multilib_src_configure() {
local mywafconfargs=(
$(usex alsa --alsa "")
$(usex dbus --dbus --classic)
)

WAF_BINARY="${BUILD_DIR}"/waf waf-utils_src_configure ${mywafconfargs[@]}
}

multilib_src_compile() {
WAF_BINARY="${BUILD_DIR}"/waf waf-utils_src_compile

if multilib_is_native_abi && use doc; then
doxygen || die "doxygen failed"
fi
}

multilib_src_install() {
multilib_is_native_abi && use doc && \
HTML_DOCS=( "${BUILD_DIR}"/html/ )
WAF_BINARY="${BUILD_DIR}"/waf waf-utils_src_install
}

multilib_src_install_all() {
python_fix_shebang "${ED}"
}
18 changes: 18 additions & 0 deletions media-sound/jack2/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Сухарик</name>
<description>Proxied maintainer</description>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo ProAudio Project</name>
</maintainer>
<use>
<flag name="pam">Add basic realime configuration via <pkg>sys-auth/realtime-base</pkg></flag>
<flag name="celt">Support CELT low delay audio codec (<pkg>media-libs/celt</pkg>)</flag>
<flag name="opus">Support <pkg>media-libs/opus</pkg></flag>
</use>
</pkgmetadata>

0 comments on commit bc49b19

Please sign in to comment.