forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/gnome-user-share: Version bump
Package-Manager: portage-2.2.24
- Loading branch information
Showing
2 changed files
with
44 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST gnome-user-share-3.14.2.tar.xz 391916 SHA256 6b05b3ef31af3bb39c903f94a0d163c0a9c4aa5266ae98e2281e0613f2972ee9 SHA512 d42587c0c64fda9d051f3d6c792358d02c32b95193df512016a04a0ee4861483f3060f1579de6fa229676795e420cf88732da334757471b79410d3be6ebe8bd1 WHIRLPOOL 14a191b8cbfa218e4dcde379212a00f0753d02726b55b16b9f67fbc2c5484038d9d18ababb5c2019624856041257a88cea6b00a3d4cf21a83c9369b9486452be | ||
DIST gnome-user-share-3.18.0.tar.xz 376944 SHA256 feb3bed59193eafea31f563ed7eab5f066aa5f86d4a89f067b162653d168d3fc SHA512 bc053b879c602f2d6d04431f817f528c7f6ffb20e2078fcef1b4cc8acbe95a658fb6cfe03b55fe87c46bd87ea175cfdfda8314928e9c3525ccf2fa8ab0fdf055 WHIRLPOOL 72c43048afae3888306c8033d63458df7fd806bf21c99405b72b5694e03e73fc5a43473671da978aea5ae223f9bf4111a809c0a9f17f47f7d38a55dd25f08817 |
43 changes: 43 additions & 0 deletions
43
gnome-extra/gnome-user-share/gnome-user-share-3.18.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,43 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
GCONF_DEBUG="no" | ||
GNOME2_LA_PUNT="yes" | ||
|
||
inherit gnome2 multilib | ||
|
||
DESCRIPTION="Personal file sharing for the GNOME desktop" | ||
HOMEPAGE="https://git.gnome.org/browse/gnome-user-share" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
# FIXME: could libnotify be made optional ? | ||
# FIXME: selinux automagic support | ||
RDEPEND=" | ||
>=dev-libs/glib-2.28:2 | ||
>=x11-libs/gtk+-3:3 | ||
>=gnome-base/nautilus-2.91.7 | ||
media-libs/libcanberra[gtk3] | ||
>=www-apache/mod_dnssd-0.6 | ||
>=www-servers/apache-2.2[apache2_modules_dav,apache2_modules_dav_fs,apache2_modules_authn_file,apache2_modules_auth_digest,apache2_modules_authz_groupfile,apache2_mpms_prefork] | ||
>=x11-libs/libnotify-0.7:= | ||
" | ||
DEPEND="${RDEPEND} | ||
!<gnome-base/gnome-control-center-3.9 | ||
app-text/yelp-tools | ||
app-text/docbook-xml-dtd:4.1.2 | ||
>=dev-util/intltool-0.35 | ||
sys-devel/gettext | ||
virtual/pkgconfig | ||
" | ||
|
||
src_configure() { | ||
gnome2_src_configure \ | ||
--with-httpd=apache2 \ | ||
--with-modules-path=/usr/$(get_libdir)/apache2/modules/ | ||
} |