forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
kde-frameworks/kconfigwidgets: 5.109.0 version bump
Signed-off-by: Andreas Sturmlechner <[email protected]>
- Loading branch information
Showing
2 changed files
with
41 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST kconfigwidgets-5.108.0.tar.xz 2613780 BLAKE2B 4cdee047ed1ee26a583e801365f9e020055f3b17a40c62876da17352b508f2200f27d3e5ef43ce54c2ca1583cc3602d87e3751ea1a946d620c98f27457c5be0b SHA512 6f01439c93bd52b3d398e6e2cf79da10a5370eb4710bc3153f879bc8da1b6b8fa704f9c47e56d4463feed936d49085f4c70a47a27b699d3252167b5b78f19eab | ||
DIST kconfigwidgets-5.109.0.tar.xz 2613840 BLAKE2B 196cc732a226032ba417be33ba1998679c6d8d71181ddc7e1d80170363292eee6cf393419c0565ebb64203287d32720b93c8f9f45ffb77bea45904ea580e3bd1 SHA512 e819a615c5c3d86f4f9c343fd2f02587980705bd5f20ac9cef30e817ec16ab03da3a6d136bcfaae6a645cf02e9d416808ca831ef64a66d814199ac7dff4a8d90 |
40 changes: 40 additions & 0 deletions
40
kde-frameworks/kconfigwidgets/kconfigwidgets-5.109.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,40 @@ | ||
# Copyright 1999-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
ECM_DESIGNERPLUGIN="true" | ||
PVCUT=$(ver_cut 1-2) | ||
QTMIN=5.15.9 | ||
inherit ecm frameworks.kde.org | ||
|
||
DESCRIPTION="Framework providing an assortment of configuration-related widgets" | ||
|
||
LICENSE="LGPL-2+" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv" | ||
IUSE="+man" | ||
|
||
RDEPEND=" | ||
>=dev-qt/qtdbus-${QTMIN}:5 | ||
>=dev-qt/qtgui-${QTMIN}:5 | ||
>=dev-qt/qtwidgets-${QTMIN}:5 | ||
=kde-frameworks/kauth-${PVCUT}*:5 | ||
=kde-frameworks/kcodecs-${PVCUT}*:5 | ||
=kde-frameworks/kconfig-${PVCUT}*:5 | ||
=kde-frameworks/kcoreaddons-${PVCUT}*:5 | ||
=kde-frameworks/kguiaddons-${PVCUT}*:5 | ||
=kde-frameworks/ki18n-${PVCUT}*:5 | ||
=kde-frameworks/kwidgetsaddons-${PVCUT}*:5 | ||
" | ||
DEPEND="${RDEPEND} | ||
test? ( =kde-frameworks/kconfig-${PVCUT}*:5[dbus] ) | ||
" | ||
BDEPEND="man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )" | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
$(cmake_use_find_package man KF5DocTools) | ||
) | ||
|
||
ecm_src_configure | ||
} |