forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Conrad Kostecki <[email protected]>
- Loading branch information
Showing
2 changed files
with
37 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST level-zero-1.17.19.tar.gz 1150799 BLAKE2B 6c6077424c503b194b93801f0c1a4cab10e53d845ef88d75fae22d8c4ebd91387e03b1e9b37f6dfa43603216f64f20095b43b6b8331e282470c7c7ab1e49204e SHA512 bc5f65180c399a0fb9504db2f3db65c04e32e9fbedd6b0c4ae9eabd77c3586eb5116e553e2a6eab85f738d7a95a2f976062d2f7216fa0c239efb6661c2b6dd2c | ||
DIST level-zero-1.17.28.tar.gz 1151085 BLAKE2B e47c8821063f7ebe03ba8af601518a9e0f97550299edac5749a4f142c4b3edfe83fd81fda2af02df5089947d6138a9b7ebf3ee7e0eed6db8b8a80eeca4c48a40 SHA512 0498ec279ab73a61ccd4a2c27a8c3837090004e0730c01e92ef6e91f32000ca9e91167b87fbec66668674d86b5dede51470ce4c77dafb58f8b4d982db8b6e490 | ||
DIST level-zero-1.17.42.tar.gz 1152554 BLAKE2B a9b2054a620735490d1ff0f0a7e35e96bfe80531cf738e11ae3316bc0ce06108304e6f55ca57c2392a7854d7015bf2bcab93aa9778784ec546da41e174a08298 SHA512 c16c8269c82888c80c226e2e67641a3dbe0dd49b7e00ce5b2b8f90ab1233ac4bba1032f0b00c9dd702b85e1f635210bc383ec0c7e74651514ac104f5d9e8300c |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,36 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit cmake | ||
|
||
DESCRIPTION="oneAPI Level Zero headers, loader and validation layer" | ||
HOMEPAGE="https://github.com/oneapi-src/level-zero" | ||
SRC_URI="https://github.com/oneapi-src/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="MIT" | ||
SLOT="0/${PV}" | ||
KEYWORDS="~amd64" | ||
|
||
RDEPEND="dev-libs/spdlog:=" | ||
DEPEND="${RDEPEND}" | ||
|
||
src_prepare() { | ||
# Don't hardcore -Werror | ||
sed -e 's/-Werror//g' -i CMakeLists.txt || die | ||
|
||
cmake_src_prepare | ||
|
||
# According to upstream, release tarballs should contain this file but at least | ||
# some of them do not. Fortunately it is trivial to make one ourselves. | ||
echo "$(ver_cut 3)" > "${S}"/VERSION_PATCH || die | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DSYSTEM_SPDLOG="ON" | ||
) | ||
|
||
cmake_src_configure | ||
} |