Skip to content

Commit

Permalink
dev-python/ipyparallel: version bump to 6.0.1.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.3
Closes: gentoo#3953
  • Loading branch information
marbre authored and monsieurp committed Feb 14, 2017
1 parent 4ab3674 commit bd075a8
Show file tree
Hide file tree
Showing 2 changed files with 67 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/ipyparallel/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST ipyparallel-4.1.0.tar.gz 2271608 SHA256 c943f6b3bbabb9332336d15474969e2a7a7
DIST ipyparallel-5.0.1.tar.gz 2350472 SHA256 48e319c16995a697c82e72dc4e5cb977be45cb0f0cdcfc482d5e8019ea6afeb2 SHA512 b7fa4f2ec5375398a533c92f07e2ab09180e537366c36ff5a7f3245d63072006ebcffc19dda28d08d5cc2e8a9044bf9101c7eeccf2857ed4a78ddd859ce23a2c WHIRLPOOL 350f67f7f341fe83bd21fb5f84714c43a426fa0d2234a532e781d0b0e9a977e2ee455184da995f5a3fbbf8e260d776dd9ac2607ac86041b5abecf41aeb9a8a9b
DIST ipyparallel-5.1.1.tar.gz 2360986 SHA256 c46cd3bad50bbe12106257241d671ce6edb3faca2ced54ed001b8f1d579720f0 SHA512 66edfafeb6ca99b04ad08a61bbe7cbcfd9ba2689d16d19c476685d73f44ec40a4f2cde75e8394dbdc3b9e4da333afdfff8960bc9f37503aa4b28af90c63878db WHIRLPOOL eebf9c71b67c9ce129e125ca3ed7fb81f38ffb604805b861cc3239e113da52c1fb939fbf400d6c0cc7cfa29330ed60730a36447f7e74c45d788b33e6f1ac60ed
DIST ipyparallel-5.2.0.tar.gz 2362590 SHA256 d99e760f1a136b1c402755a4ab51a8d7cb87c892cccadf641948a5e886c8a455 SHA512 1a3a4be28847ad11d43d96192ded62506380374b96a14cc9a6d6e945ac9592da7543fb5f9626a112068e548ed27f3291894a3cef544c65476c22b397458f60f3 WHIRLPOOL 29a77df915dfb487adabfb89ea96ee66253c14c7968699826f5be01073b43c753a2985bd940e09a708c92b4e9945b16d855b65a568523b1a75688a4aca022bca
DIST ipyparallel-6.0.1.tar.gz 2368258 SHA256 968da8dbf0d3cad97d588994da6739851ec7ae9e98f851a333adb4eff3d930f0 SHA512 53aa947b05813a8e29b0d2bd74d37bd821fe96040fef1d25d29a7a40867dd30a5dd462f7c9a488aa565c897e2f9816e2b9e24150023aa03433c2c86574d928b6 WHIRLPOOL 6bedb1cbba4c9a8fd3f807365bd851bb0c6eb3daf8248bec4aff65c67857bf934cdbf53007cc33d47ea03558fdeb7f418d77bc6422725e820cb5f19639f97768
66 changes: 66 additions & 0 deletions dev-python/ipyparallel/ipyparallel-6.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5} )
PYTHON_REQ_USE="threads(+)"

inherit distutils-r1

DESCRIPTION="Interactive Parallel Computing with IPython"
HOMEPAGE="http://ipython.org/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="doc test"

RDEPEND="
dev-python/ipython_genutils[${PYTHON_USEDEP}]
dev-python/decorator[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
>=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
dev-python/ipykernel[${PYTHON_USEDEP}]
!<dev-python/ipython-4.0.0[smp]
>=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
dev-python/notebook[${PYTHON_USEDEP}]
dev-python/jupyter_client[${PYTHON_USEDEP}]
www-servers/tornado[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
$(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' 'python2*')
>=dev-python/setuptools-18.5[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/testpath[${PYTHON_USEDEP}]
)
"

python_prepare_all() {
# Prevent un-needed download during build
if use doc; then
sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
fi

distutils-r1_python_prepare_all
}

python_compile_all() {
if use doc; then
emake -C docs html
HTML_DOCS=( "${BUILD_DIR}"/docs/build/html/. )
fi
}

python_test() {
iptest --coverage xml ipyparallel.tests -- -vsx || die
}

python_install_all() {
distutils-r1_python_install_all
}

0 comments on commit bd075a8

Please sign in to comment.