Skip to content

Commit

Permalink
games-mud/lyntin: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0
  • Loading branch information
austin987 committed Aug 5, 2016
1 parent 0ff49b3 commit bd106ae
Showing 1 changed file with 54 additions and 0 deletions.
54 changes: 54 additions & 0 deletions games-mud/lyntin/lyntin-4.2-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="tk?"

inherit distutils-r1

DESCRIPTION="tintin mud client clone implemented in Python"
HOMEPAGE="http://lyntin.sourceforge.net/"
SRC_URI="mirror://sourceforge/lyntin/${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="tk"

DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""

DOCS=( COMMANDS PKG-INFO HACKING README )

python_install() {
distutils-r1_python_install --install-scripts=/usr/bin
}

src_prepare() {
distutils-r1_src_prepare
}

src_compile() {
distutils-r1_src_compile
}

src_install() {
distutils-r1_src_install
}

pkg_postinst() {
if use tk ; then
elog "To start lyntin in GUI mode, create a config file"
elog "with this in it:"
elog
elog "[Lyntin]"
elog "ui: tk"
elog
elog "Then start lyntin like this:"
elog
elog "runlyntin -c /path/to/config_file\n"
fi
}

0 comments on commit bd106ae

Please sign in to comment.