Skip to content

Commit

Permalink
app-misc/gnote: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.24
  • Loading branch information
pacho2 committed Dec 12, 2015
1 parent d5f57bf commit bd19d6c
Show file tree
Hide file tree
Showing 2 changed files with 81 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/gnote/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gnote-3.16.2.tar.xz 3068136 SHA256 5c5b55b5c548d15e344d59fdd2a0260b1acbd13a9fa4cf9bfc1fe6e68a041e07 SHA512 b9d405ad8392d526fcb4098952c6531ba99b1a9b74a1bb857886b3017b676938e001ea7332bd189d5bdbbf554b40bcff57c995d6391135d4176ba00529d4b130 WHIRLPOOL c6d94674093eb1883b87c5da9d302c99f73fd32e51d728b406d2f8f8a40cc8eac85e6be39f5d0ad38d5f492699c1d97a7e642dc31df791cde16b09957d98f418
DIST gnote-3.18.0.tar.xz 3300404 SHA256 4828363ae3ddac57d37a0a2b17882be8fe67afcecf97ae992cd744b95da1c348 SHA512 76802759353a11278e4f47a14dc62d3d3bcec61a0a05619cc151bde1969a4675aba26f04b77406dd5f9074b292ec9b8c1288e4e00cb1577141d7bd605416acc0 WHIRLPOOL d2a55d3de08f460edaf8f8c8446766fccbe0c6aff43e82532b00b8e0af8932cdbfda573392e28cc9d9ee47ac8959cc8b23f98a2b3273761ec431dfdd9017f0f0
DIST gnote-3.18.1.tar.xz 3310004 SHA256 5da4ec9e7852b09af1067311fc6ee18a2c64384f4f5943b71ac37665144be58d SHA512 bd67f43494c8367a1b435a44408ed8fa7f50e380d09fedcb27874d7b38791ed65fb68e524946188859f58588625f436a58fb85d8429bd1ec1daf47328a74bc57 WHIRLPOOL 5df84e22467903159fa49eb1840b9fbfc0f8cf341ff1ff673c71cce1ebb1a5d3d85e1375d1ed21e7232f328078752153d0aa5929e8756963b65658e45fd671dd
80 changes: 80 additions & 0 deletions app-misc/gnote/gnote-3.18.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,80 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"

inherit autotools eutils gnome2 readme.gentoo

DESCRIPTION="Desktop note-taking application"
HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"

LICENSE="GPL-3+ FDL-1.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug X"

# Automagic glib-2.32 dep
COMMON_DEPEND="
>=app-crypt/libsecret-0.8
>=app-text/gtkspell-3.0:3
>=dev-cpp/glibmm-2.32:2
>=dev-cpp/gtkmm-3.10:3.0
>=dev-libs/boost-1.34
>=dev-libs/glib-2.32:2[dbus]
>=dev-libs/libxml2-2:2
dev-libs/libxslt
>=sys-apps/util-linux-2.16:=
>=x11-libs/gtk+-3.10:3
X? ( x11-libs/libX11 )
"
RDEPEND="${COMMON_DEPEND}
gnome-base/gsettings-desktop-schemas
"
DEPEND="${DEPEND}
app-text/docbook-xml-dtd:4.1.2
dev-util/desktop-file-utils
>=dev-util/intltool-0.35.0
dev-util/itstool
virtual/pkgconfig
"

src_prepare() {
# Fix x11-support switch
# https://bugzilla.gnome.org/show_bug.cgi?id=758636
epatch "${FILESDIR}"/${PN}-3.18.2-x11-support-switch.patch

# Do not alter CFLAGS
sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die

eautoreconf
gnome2_src_prepare

if has_version net-fs/wdfs; then
DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
synchronize notes."
else
DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
If you want to use that functionality just emerge net-fs/wdfs.
Gnote will automatically detect that you did and let you use it."
fi
}

src_configure() {
gnome2_src_configure \
--disable-static \
$(use_enable debug) \
$(use_with X x11-support)
}

src_install() {
gnome2_src_install
readme.gentoo_create_doc
}

pkg_postinst() {
gnome2_pkg_postinst
readme.gentoo_print_elog
}

0 comments on commit bd19d6c

Please sign in to comment.