forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/chrome-gnome-shell: version bump
Closes: gentoo#4432
- Loading branch information
Showing
2 changed files
with
61 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST chrome-gnome-shell-7.1.tar.xz 99712 SHA256 0a1d791a149ceabdaec09bd65656781fde20618bd219f467a9f50f3c57d4842f SHA512 da41068049c4d221cf7e1ed6d171fb63cd236ab5afc7374ec72774da092630ca1fb459b178c364a3d014919aedd3e875c1c698b5a42d4e3c7a2f49e0f2610743 WHIRLPOOL 04edac7e7980723833df589a70e46f474e71e1fe2e771ed98cd3e9181c890fc501b20aa3665c5322fcc9286771820fee08160d6dfc37ad084767db7db5812330 | ||
DIST chrome-gnome-shell-8.1.tar.xz 145404 SHA256 27fa50a185aa1f4db5458d71fedfafba16a45498dc9cb619a2db9cd1dc8ae33e SHA512 90fc047aece51e8cee24d65033db1f32f6ddb90d24a63127248b0dc824f26dab3a5cb169e179a17c7b26aacb7d8417101f5a7695c979417e9f8464a9672b34d2 WHIRLPOOL 2ad77e3acbf760dab1547002e383cbf438b09931de3ea01c6302fe12ff5648a23e72cd32bdc6b431e8c1f6cd57a4b746ab071a67389e2de8f9ad0e826a17905b | ||
DIST chrome-gnome-shell-8.tar.xz 143224 SHA256 2621a1e0762ff39473180a0eed49414594ea3eae4812acd584d89374221b37c5 SHA512 61acd4b0564892667bd1468430ddfff4c0cfbe92b573d8b7e4c5448c25266bd0ee6e89e9bebe08553de4f9661ceeea46f5af38d980051491c40ed7deb24e3277 WHIRLPOOL 9e6de120bc84a4f431201753587864f6878eca0937624eccaea60e9f7c20a385ee0867107f823b131dc58e0bac121cdccda6e42861a5bc4ebbb45b7be7b374f8 | ||
DIST chrome-gnome-shell-9.tar.xz 151984 SHA256 11fdfaa12208ec87ddbac27fc9652609c74e421d3e258de6b4776e392efdd448 SHA512 b9b5f913a74bdfa641ce35c62f15aa1ceff37e6e0fef43c127ff8ba31933ba2d9c93ee50809b013336ec63ae1020d4e1cacd56d9a86204e1ba4c0bd1d8ed50cf WHIRLPOOL 918a640f8da15b4ecb71870fb400f791c72ded75a3bfeaeb74a22c229afcde6f9497cc2c94ff2665f7d0cd7ea0dac83fe08870c3a3e590f3b425a44cb1b832a0 |
60 changes: 60 additions & 0 deletions
60
gnome-extra/chrome-gnome-shell/chrome-gnome-shell-9.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,60 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
PYTHON_COMPAT=( python2_7 python3_{4,5} ) | ||
|
||
inherit cmake-utils python-single-r1 | ||
|
||
DESCRIPTION="GNOME Shell integration for Chrome/Chromium, Firefox, Vivaldi, Opera browsers" | ||
HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShellIntegrationForChrome" | ||
SRC_URI="mirror://gnome/sources/${PN}/${PV}/${P}.tar.xz" | ||
|
||
LICENSE="GPL-3+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
REQUIRED_USE="${PYTHON_REQUIRED_USE}" | ||
|
||
DEPEND="${PYTHON_DEPS} | ||
app-misc/jq | ||
sys-apps/coreutils | ||
" | ||
RDEPEND="${PYTHON_DEPS} | ||
dev-python/pygobject:3[${PYTHON_USEDEP}] | ||
dev-python/requests[${PYTHON_USEDEP}] | ||
gnome-base/gnome-shell | ||
" | ||
|
||
src_configure() { | ||
local mycmakeargs=( -DBUILD_EXTENSION=OFF ) | ||
cmake-utils_src_configure | ||
} | ||
|
||
src_install() { | ||
# Chrome policy files should be removed with package. | ||
# Otherwise it will not be possible to uninstall web extension | ||
# from browser. | ||
echo -n "CONFIG_PROTECT_MASK=\"" > 50"${PN}" || die | ||
echo -n "/etc/chromium/policies/managed/${PN}.json " >> 50"${PN}" || die | ||
echo "/etc/opt/chrome/policies/managed/${PN}.json\"" >> 50"${PN}" || die | ||
doenvd 50"${PN}" | ||
|
||
cmake-utils_src_install | ||
} | ||
|
||
pkg_postinst() { | ||
elog "Please note that this package provides native messaging connector only." | ||
elog | ||
elog "Managed policy was installed to force browser extension installation" | ||
elog "for Google Chrome, Chromium and Vivaldi browsers from Chrome Store" | ||
elog "https://chrome.google.com/webstore/detail/gphhapmejobijbbhgpjhcjognlahblep" | ||
elog | ||
elog "For Mozilla Firefox you should manualy install browser extension from" | ||
elog "https://addons.mozilla.org/firefox/addon/gnome-shell-integration/" | ||
elog | ||
elog "For Opera you should manualy install browser extension from" | ||
elog "https://addons.opera.com/extensions/details/gnome-shell-integration/" | ||
} |