Skip to content

Commit

Permalink
media-libs/libprojectm: Add dependency on media-libs/glm
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/670428
Package-Manager: Portage-2.3.51, Repoman-2.3.12
Signed-off-by: Craig Andrews <[email protected]>
  • Loading branch information
candrews committed Nov 6, 2018
1 parent 931ea67 commit bd33498
Show file tree
Hide file tree
Showing 2 changed files with 106 additions and 0 deletions.
55 changes: 55 additions & 0 deletions media-libs/libprojectm/libprojectm-3.1.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools

DESCRIPTION="A graphical music visualization plugin similar to milkdrop"
HOMEPAGE="https://github.com/projectM-visualizer/projectm"

if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/projectM-visualizer/projectm.git"
inherit git-r3
else
SRC_URI="https://github.com/projectM-visualizer/projectm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
S=${WORKDIR}/projectm-${PV}/
fi

LICENSE="LGPL-2"
SLOT="0"
IUSE="gles2 qt5 sdl"

RDEPEND="gles2? ( media-libs/mesa[gles2] )
media-libs/glm
media-libs/mesa
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
dev-qt/qtopengl:5
media-sound/pulseaudio
)
sdl? ( >=media-libs/libsdl2-2.0.5 )
sys-libs/zlib"

DEPEND="${RDEPEND}
virtual/pkgconfig"

PATCHES=(
"${FILESDIR}/${P}-datadir.patch"
)

src_prepare() {
default
eautoreconf
}

src_configure() {
econf \
$(use_enable gles2 gles ) \
$(use_enable qt5 qt ) \
$(use_enable sdl ) \
--enable-emscripten=no
}
51 changes: 51 additions & 0 deletions media-libs/libprojectm/libprojectm-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools

DESCRIPTION="A graphical music visualization plugin similar to milkdrop"
HOMEPAGE="https://github.com/projectM-visualizer/projectm"

if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/projectM-visualizer/projectm.git"
inherit git-r3
else
SRC_URI="https://github.com/projectM-visualizer/projectm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
S=${WORKDIR}/projectm-${PV}/
fi

LICENSE="LGPL-2"
SLOT="0"
IUSE="gles2 qt5 sdl"

RDEPEND="gles2? ( media-libs/mesa[gles2] )
media-libs/glm
media-libs/mesa
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
dev-qt/qtopengl:5
media-sound/pulseaudio
)
sdl? ( >=media-libs/libsdl2-2.0.5 )
sys-libs/zlib"

DEPEND="${RDEPEND}
virtual/pkgconfig"

src_prepare() {
default
eautoreconf
}

src_configure() {
econf \
$(use_enable gles2 gles ) \
$(use_enable qt5 qt ) \
$(use_enable sdl ) \
--enable-emscripten=no
}

0 comments on commit bd33498

Please sign in to comment.