Skip to content

Commit

Permalink
sys-devel/clang-runtime: Add 17.0.0_pre20230615 snapshot
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Jun 17, 2023
1 parent d657d8c commit bd40dde
Showing 1 changed file with 41 additions and 0 deletions.
41 changes: 41 additions & 0 deletions sys-devel/clang-runtime/clang-runtime-17.0.0_pre20230615.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit multilib-build toolchain-funcs

DESCRIPTION="Meta-ebuild for clang runtime libraries"
HOMEPAGE="https://clang.llvm.org/"

LICENSE="metapackage"
SLOT="${PV%%.*}"
KEYWORDS=""
IUSE="+compiler-rt libcxx openmp +sanitize"
REQUIRED_USE="sanitize? ( compiler-rt )"
PROPERTIES="live"

RDEPEND="
compiler-rt? (
~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
sanitize? (
~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
)
)
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
"

pkg_pretend() {
if tc-is-clang; then
ewarn "You seem to be using clang as a system compiler. As of clang-16,"
ewarn "upstream has turned a few warnings that commonly occur during"
ewarn "configure script runs into errors by default. This causes some"
ewarn "configure tests to start failing, sometimes resulting in silent"
ewarn "breakage, missing functionality or runtime misbehavior. It is"
ewarn "not yet clear whether the change will remain or be reverted."
ewarn
ewarn "For more information, please see:"
ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
fi
}

0 comments on commit bd40dde

Please sign in to comment.