forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-pda/libusbmuxd: fix configure breakage with clang-16
Closes: https://bugs.gentoo.org/893910 Signed-off-by: Matthew Smith <[email protected]>
- Loading branch information
1 parent
1c260cc
commit bd85cb9
Showing
2 changed files
with
72 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,32 @@ | ||
From 84fb81483703dfcc26e784256b6a19d75e8e58ee Mon Sep 17 00:00:00 2001 | ||
From: Matthew Smith <[email protected]> | ||
Date: Sun, 12 Feb 2023 10:18:02 +0000 | ||
Subject: [PATCH] autoconf: Fix -Wint-conversion in test | ||
|
||
-Wint-conversion becomes an error by default in clang-16, causing the | ||
program_invocation_short_name test to fail. | ||
|
||
Bug: https://bugs.gentoo.org/893910 | ||
--- a/configure.ac | ||
+++ b/configure.ac | ||
@@ -87,7 +87,7 @@ case ${host_os} in | ||
]) | ||
AC_CHECK_FUNCS([pselect]) | ||
AC_CACHE_CHECK(for program_invocation_short_name, ac_cv_program_invocation_short_name,[ | ||
- AC_TRY_LINK([extern char* program_invocation_short_name;],[return program_invocation_short_name;], | ||
+ AC_TRY_LINK([extern char* program_invocation_short_name;],[return program_invocation_short_name[0];], | ||
[ac_cv_program_invocation_short_name=yes], | ||
[ac_cv_program_invocation_short_name=no] | ||
) | ||
@@ -95,7 +95,7 @@ case ${host_os} in | ||
if test "x$ac_cv_program_invocation_short_name" = "xyes"; then | ||
AC_DEFINE(HAVE_PROGRAM_INVOCATION_SHORT_NAME, 1, [Define if you have program_invocation_short_name]) | ||
AC_CACHE_CHECK(if program_invocation_short_name is declared in errno.h, ac_cv_program_invocation_short_name_errno_h,[ | ||
- AC_TRY_LINK([#include <errno.h>],[return program_invocation_short_name;], | ||
+ AC_TRY_LINK([#include <errno.h>],[return program_invocation_short_name[0];], | ||
[ac_cv_program_invocation_short_name_errno_h=yes], | ||
[ac_cv_program_invocation_short_name_errno_h=no] | ||
) | ||
-- | ||
2.39.1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,40 @@ | ||
# Copyright 1999-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit autotools | ||
|
||
DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices" | ||
HOMEPAGE="https://www.libimobiledevice.org/" | ||
SRC_URI="https://cgit.libimobiledevice.org/${PN}.git/snapshot/${P}.tar.bz2" | ||
LICENSE="GPL-2+ LGPL-2.1+" # tools/*.c is GPL-2+, rest is LGPL-2.1+ | ||
SLOT="0/2.0-6" # based on SONAME of libusbmuxd-2.0.so | ||
KEYWORDS="amd64 ~arm ~arm64 ~loong ppc ~ppc64 ~riscv x86" | ||
IUSE="static-libs" | ||
|
||
RDEPEND=" | ||
>=app-pda/libplist-2.2.0:= | ||
" | ||
DEPEND="${RDEPEND}" | ||
BDEPEND=" | ||
virtual/pkgconfig | ||
" | ||
|
||
PATCHES=( "${FILESDIR}"/libusbmuxd-2.0.2-configure.patch ) | ||
|
||
src_prepare() { | ||
default | ||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
econf \ | ||
$(use_enable static-libs static) \ | ||
$(usex kernel_linux '' --without-inotify) | ||
} | ||
|
||
src_install() { | ||
default | ||
find "${D}" -name '*.la' -type f -delete || die | ||
} |