Skip to content

Commit

Permalink
dev-php/pecl-event: fix USE=-sockets build with >=dev-lang/php-7.0
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/710100
Signed-off-by: Ruslan Osmanov <[email protected]>
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Closes: gentoo#14754
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
rosmanov authored and Whissi committed Mar 20, 2020
1 parent 5313dac commit bd88751
Show file tree
Hide file tree
Showing 2 changed files with 72 additions and 0 deletions.
12 changes: 12 additions & 0 deletions dev-php/pecl-event/files/pecl-event-2.5.3-no-sockets.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
--- a/php7/src/fe-orig.c 2020-02-23 15:50:42.159505602 +0300
+++ b/php7/src/fe.c 2020-02-23 15:51:09.985462245 +0300
@@ -640,7 +640,9 @@
PHP_ME(EventUtil, getSocketName, arginfo_event_util_get_socket_name, ZEND_ACC_PUBLIC | ZEND_ACC_STATIC)
PHP_ME(EventUtil, getSocketFd, arginfo_event_util_get_socket_fd, ZEND_ACC_PUBLIC | ZEND_ACC_STATIC)
PHP_ME(EventUtil, setSocketOption, arginfo_event_util_set_socket_option, ZEND_ACC_PUBLIC | ZEND_ACC_STATIC)
+#ifdef PHP_EVENT_SOCKETS_SUPPORT
PHP_ME(EventUtil, createSocket, arginfo_event_util_create_socket, ZEND_ACC_PUBLIC | ZEND_ACC_STATIC)
+#endif

PHP_FE_END
};
60 changes: 60 additions & 0 deletions dev-php/pecl-event/pecl-event-2.5.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

PHP_EXT_NAME="event"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
DOCS=( README.md )

USE_PHP="php7-1 php7-2 php7-3 php7-4"

inherit php-ext-pecl-r3

KEYWORDS="~amd64 ~ia64 ~x86"
LICENSE="PHP-3.01"

DESCRIPTION="PHP wrapper for libevent2"
SLOT="0"

PATCHES=(
"${FILESDIR}/${PN}-2.5.3-no-sockets.patch"
)

DEPEND="
>=dev-libs/libevent-2.0.2
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
)
php_targets_php7-1? ( dev-lang/php:7.1[sockets?] )
php_targets_php7-2? ( dev-lang/php:7.2[sockets?] )
php_targets_php7-3? ( dev-lang/php:7.3[sockets?] )
php_targets_php7-4? ( dev-lang/php:7.4[sockets?] )"

RDEPEND="
${DEPEND}
!dev-php/pecl-libevent"

IUSE="debug examples +extra libressl +sockets +ssl threads"

src_configure() {
local PHP_EXT_ECONF_ARGS=(
--with-event-core
$(use_enable debug event-debug)
$(use_with extra event-extra)
$(use_with ssl event-openssl)
$(use_with threads event-pthreads)
$(use_enable sockets event-sockets)
)
php-ext-source-r3_src_configure
}

src_test() {
local slot
for slot in $(php_get_slots); do
php_init_slot_env "${slot}"
SKIP_ONLINE_TESTS="yes" NO_INTERACTION="yes" emake test
done
}

0 comments on commit bd88751

Please sign in to comment.