Skip to content

Commit

Permalink
dev-python/docker-py: Version bump to 3.2.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.28, Repoman-2.3.9
  • Loading branch information
mrueg committed Apr 5, 2018
1 parent 3be98a5 commit bd9451b
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/docker-py/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST docker-py-2.4.2.tar.gz 180890 BLAKE2B 57518a0c8481fde0198100354225cd8a2908a
DIST docker-py-2.7.0.tar.gz 196369 BLAKE2B dd181dbf32f5afda06e748cb49f15d5fc6ff4a579c64b505308ad0d96913ddc8065d165090ec2b20e1f17a4519988a5665dd7a8c7643ca53aaa4385ceecb1341 SHA512 15cf1d8949d71e472f7636ff975cbc4c5f3e18e2d193cb603ade1397a56d0c1ec239167b71be325af99105bc36590a0f0faa1ab010f36fe8baca7807ddfa191b
DIST docker-py-3.1.4.tar.gz 202064 BLAKE2B 6ee3672cd1f62cd570d3939805465698879d747215b8424bc4edd79253c5bc25d193582dbfa6aa423f9b183d477486d6347f65ac7245d601d3f1fe2a1fd124ed SHA512 78081010ce4027156d3b4ebafee6023f387ee8e7ee4d77ee671a16a3fcb646fca91c5c36cfbaf94157f8a524a3e1a09b9cbfabf304e278a3c1e0132df5d13d13
DIST docker-py-3.2.0.tar.gz 205546 BLAKE2B 0784408a0373721e30cc101bf9e20e93af4721ace3841721b851efa49874163a1684239db6a56b7e91e83ad77eb4290dde61f53d70d6656853cedaff95da90b2 SHA512 fa36b65a047aec6dbec07b2ee5ac895b333acc804e372b5b3ccae587045fa03613f4083c66cd6289e188fd78c6f7012c4252e9bbf9f30a980fb94f32efba03b7
DIST docker-py-3.2.1.tar.gz 205815 BLAKE2B fc9b23f57f64e3d25a922b896619f3d03780d446f03adb987c6a203df2c41fbc03b202cc8dac30392158dd0da4d600372b6af284d785179c0cf58f7048735da3 SHA512 c66f960bd507d8c4ed99e56480c24d11b13cf49420eee2f0934cede7516a8a9b984e5e0540a1d82d830768d3a5f0218dddd61255d55e7bd1b984072cd6e48a44
55 changes: 55 additions & 0 deletions dev-python/docker-py/docker-py-3.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )

inherit distutils-r1

DESCRIPTION="Python client for Docker"
HOMEPAGE="https://github.com/docker/docker-py"
SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="doc test"

RDEPEND="
>=dev-python/docker-pycreds-0.2.2[${PYTHON_USEDEP}]
!~dev-python/requests-2.18.0[${PYTHON_USEDEP}]
>=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
>=dev-python/six-1.4.0[${PYTHON_USEDEP}]
>=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' 'python3_4' )
$(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
dev-python/pytest-runner[${PYTHON_USEDEP}]
>=dev-python/pytest-2.9.1[${PYTHON_USEDEP}]
)
doc? (
dev-python/recommonmark[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.4.6[${PYTHON_USEDEP}]
)
"

python_prepare_all() {
sed -i -e "s/import pip//" -e "s/if 'docker-py'.*/if False:/" setup.py || die
distutils-r1_python_prepare_all
}

python_compile_all() {
if use doc; then
sphinx-build docs html || die "docs failed to build"
HTML_DOCS=( html/. )
fi
}

python_test() {
py.test tests/unit/ || die "tests failed under ${EPYTHON}"
}

0 comments on commit bd9451b

Please sign in to comment.