Skip to content

Commit

Permalink
app-text/pdf2djvu: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
mrueg committed Feb 27, 2016
1 parent 597d4f6 commit bd9a731
Show file tree
Hide file tree
Showing 2 changed files with 54 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/pdf2djvu/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST pdf2djvu-0.8.2.tar.xz 234412 SHA256 40b0812e954f374704bd8dbb5952786f6744623a2ec6df1c56de0b8057be93d6 SHA512 72a3ee719b6311824c1f71269787b31cdd600bc8671f0486419f4d023cb10f9d338df18ce33c982ed43f893d441a723bffd502a17287be43a00dc695ca959042 WHIRLPOOL 72863dfc7f4a7d1665de77a3fa12242c83746f4c3a237b45e92fd3111581f55e16a5c020590d12185db13b7035a987ab2efaa8fee9b47adb60f0502703af6a7c
DIST pdf2djvu-0.9.1.tar.xz 238840 SHA256 9f9919e97fe244f4c49fa4074120cfc03397379b39f32a911793088039c63df5 SHA512 9ccc5a5523f9b9f17f67912a63f0314eac93a633282bb8bee95bcd9b0f50ef2d05ddbb3456daee7b8d5795081c27002ffc355e6effcfbee4ce9a52b7f92bdf50 WHIRLPOOL ae3e531a5de524e03cd353af54bb4171a62fc01b4162ec31b2401eea53732acb13fed80f3b5eb7ed797080b1b2aab5908d6666a95068b0583b3f8ce92130897e
DIST pdf2djvu-0.9.3.tar.xz 239492 SHA256 d05eb7a10e22d18b77113831ac1c6e380c4569e021c39554d5bb54effe4c7077 SHA512 388b76642c354480674b6eee4961792c4ef483313ffd25a6248d1d6302985ac5adfb558ae9241062893a419463c9626d8dac9d08297d66b68a98cebbcc4dc193 WHIRLPOOL 76f5d53c11c921968eaf9f91b4fcf7ff25bd6405b6f92638af4fd38c5931941f6c48f4ba586d0ef3a6f5f8bdcfff68b1681c6429e32c818ffe379bd3a6891bfc
DIST pdf2djvu-0.9.4.tar.xz 250332 SHA256 c5702283fc6f39e8c0c49c2dc67b95e321dc926199bc77578d3daeef4de62fa8 SHA512 6b97d0577ee6e623d8c877393f551dd2a5e19508e5cd6dc5bb2d3ae1a2b71c2f0ffc7020d85507bc52a25da09a301dd5ddf45ab2628928477e0846707ea57322 WHIRLPOOL 007e1d2a150ca1300d67852ef6ee5e47e0ab36c253d0628438f3a199c42b889613f0aeb8d2ab661555d87bf0b913975ffa65f80fc3d9c5fad475d581d13fb2b6
53 changes: 53 additions & 0 deletions app-text/pdf2djvu/pdf2djvu-0.9.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 )

inherit python-single-r1 toolchain-funcs

DESCRIPTION="A tool to create DjVu files from PDF files"
HOMEPAGE="http://jwilk.net/software/pdf2djvu"
SRC_URI="https://bitbucket.org/jwilk/${PN}/downloads/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+graphicsmagick nls openmp test"

RDEPEND="
>=app-text/djvu-3.5.21:=
>=app-text/poppler-0.16.7:=
dev-libs/libxml2:=
dev-libs/libxslt:=
graphicsmagick? ( media-gfx/graphicsmagick:= )
"
DEPEND="${RDEPEND}
dev-cpp/pstreams
virtual/pkgconfig
nls? ( sys-devel/gettext )
test? ( dev-python/nose[${PYTHON_USEDEP}] )
"

REQUIRED_USE="test? ( graphicsmagick ${PYTHON_REQUIRED_USE} )"

pkg_setup() {
use test && python-single-r1_pkg_setup
}

src_configure() {
local openmp=--disable-openmp
use openmp && tc-has-openmp && openmp=--enable-openmp

econf \
${openmp} \
$(use_enable nls) \
$(use_with graphicsmagick)
}

src_install() {
default
dodoc doc/{changelog,{cjk,credits,djvudigital}.txt}
}

0 comments on commit bd9a731

Please sign in to comment.