Skip to content

Commit

Permalink
dev-ruby/bundler: add 1.11.2
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.24
  • Loading branch information
graaff committed Dec 20, 2015
1 parent 9db9499 commit bde2a96
Show file tree
Hide file tree
Showing 2 changed files with 70 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/bundler/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST bundler-1.10.6.tar.gz 313526 SHA256 6c700c2183577be4991b82a975b981bf85a6eb32c9a9a86027aa8e88f1768c19 SHA512 63791bca60c0981aebd69a8fab8bd3741976a0c2a94a5d99f54560917e3a9661b87812385d88a9b858e8d08ffe3b68b42e1c06eb8370dd216713fd6daa1a2166 WHIRLPOOL f74fdfa82a96a8bb3f695bd4126283bc1076a42944227476bda98084e8e50f56e87508f8e63f102fc6297f38ae6325130a9750ee1ccb340c2163d35ab1ed1e36
DIST bundler-1.11.2.tar.gz 329289 SHA256 8f84487d197f7fcd1753dbe92403febb1ad1ac4ef847fadb473ca9ec62647c8d SHA512 04f324b1a6c23b4e92f2b8c1c974a9420af21f95569b8617d600c9d307af142d109c606cce5f64601e79620f31194d1b4b9f72982b7009c37c5a7a5dd1d973a6 WHIRLPOOL 45fb426c454da025c938bab216f6cd41832779b827736aa66b8536877ae5eb161813f34ffcd1280f410a55140673ad10916f4407bf894eec6c23fcad0045ba80
DIST bundler-1.8.9.tar.gz 290462 SHA256 9ecbe18147b990e8c5c7f299e9bc7b63eb274f54b05134ad334e0abeb943f733 SHA512 2e3378e2c329c53eb6e578b496e1fb332c4f96eca58299e59dd8cb7f5d3b78f43bc6bf96c452cbeb99a0459c016a824248f907b58dcc2081490e4f59ea7a32ba WHIRLPOOL 887a72075093405dd5c94902865589e4946d70f1cc390725e8ae35f6a36cdc2bdd05b9c27958a5c2497d6f42011791c2432f15ab45e1ccbc8c7f0d7da37799c9
DIST bundler-1.9.10.tar.gz 301546 SHA256 ea56d906a96f14ffb8ebd3bd5f35ebb4389901be10c8470f6741d6567f16f844 SHA512 0cd05ae67543c5993d2e33cc9287dc375703cda3250de3556442ae513825b200d534640a9232806b1c4bdec192937de2b40d54563030d9aff8f7727f349a7b17 WHIRLPOOL ac2a118bd85d5b6c9ef2819dec95c6580c769a4985429fd959cffc0e0a6be1f6e37106b2d713e42c360dd19761b71f93dbf519f68fd5bcda0ffb09f97e5eff89
69 changes: 69 additions & 0 deletions dev-ruby/bundler/bundler-1.11.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,69 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

USE_RUBY="ruby20 ruby21 ruby22"

#RUBY_FAKEGEM_RECIPE_TEST="rspec3"

# No documentation task
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md ISSUES.md"

RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"

inherit ruby-fakegem

DESCRIPTION="An easy way to vendor gem dependencies"
HOMEPAGE="https://github.com/carlhuda/bundler"
SRC_URI="https://github.com/carlhuda/bundler/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="doc test"

ruby_add_rdepend virtual/rubygems

ruby_add_bdepend "doc? ( app-text/ronn )"

# ruby_add_bdepend "test? ( app-text/ronn )"

# The specs require a number of gems to be installed in a temporary
# directory, but this requires network access. All tests should still
# pass with network access.
RESTRICT="test"

RDEPEND+=" dev-vcs/git"

all_ruby_prepare() {
# Bundler only supports running the specs from git:
# https://github.com/carlhuda/bundler/issues/issue/738
sed -i -e '/when Bundler is bundled/,/^ end/ s:^:#:' spec/runtime/setup_spec.rb || die

# Fails randomly and no clear cause can be found. Might be related
# to bug 346357. This was broken in previous releases without a
# failing spec, so patch out this spec for now since it is not a
# regression.
sed -i -e '/works when you bundle exec bundle/,/^ end/ s:^:#:' spec/install/deploy_spec.rb || die

# Remove unneeded git dependency from gemspec, which we need to use
# for bug 491826
sed -i -e '/files/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die

# Avoid specs that are not compatible with all rspec versions.
sed -e '/has no malformed whitespace/,/^ end/ s:^:#:' \
-e '/uses double-quotes consistently/,/^ end/ s:^:#:' \
-i spec/quality_spec.rb || die

# Avoid spec failing with git 2.0.
sed -i -e '/on releasing/,/^ end/ s:^:#:' spec/bundler/gem_helper_spec.rb || die
}

each_ruby_compile() {
if use doc ; then
${RUBY} -S rake man:build || die
fi
}

0 comments on commit bde2a96

Please sign in to comment.