forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Alarig Le Lay <[email protected]> Closes: gentoo#19023 Signed-off-by: Joonas Niilola <[email protected]>
- Loading branch information
Showing
3 changed files
with
104 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST wavemon-0.8.0.tar.gz 196353 BLAKE2B 90d358d325b62ba9379ea525c4399e38c38043e67460b20188c4d81261d290e8e3f154a33240882f8b2611e4db1862d7bd33c87e168569be9d751d431602da81 SHA512 2df48eb300e9b30e0cb7a0ab41ba5e10b2a6e8170dbd11a4c978462c8cd6dc1171f79ceadfdb7344c495420a4e87b7dd723efea4f1af59a6d0312d93049ee798 | ||
DIST wavemon-0.9.2.tar.gz 202575 BLAKE2B 0a1afe1081bbbeb2ba0fec4741df7da846b65bbf182e886b2185c5e406258a1ecf912509b1a8f4862f37ba92832240dc6db4305a8d5cfb6f4876f3e93b04ccc7 SHA512 f1ee2e4602e93f0639c10067d23df021101bfc0496e53b221cd1553ebc90876cdd963cd64d5ef503da6d4dc4fbcf640e78873df1bdf64272e70dfa3c53ec1706 | ||
DIST wavemon-0.9.3.tar.gz 220372 BLAKE2B 383e5462e6f3abf86b3604499764060927321018f9dfaef9b742d933e832e568249e41f348788184e125324f81672f2f2b2ff9ca970c215f95a80ec140e0ca11 SHA512 0e4f6db1dfd1915a3c0e1c9708eea501d7180e80df891d0c5a59bb72d48777731c67a256d2d7d6c748ade8e1a3efad9004f5e13971e0b4e16eefdd4f8c6fe1c1 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,49 @@ | ||
--- a/configure.ac 2020-12-26 17:44:01.616731241 +0100 | ||
+++ b/configure.ac 2020-12-26 17:45:02.447292151 +0100 | ||
@@ -8,8 +8,6 @@ | ||
AC_CONFIG_AUX_DIR([config]) | ||
AC_CONFIG_FILES([Makefile]) | ||
|
||
-CFLAGS="-O2 -Wall" | ||
- | ||
# wavemon is only supported on Linux, warn user about futile compilations | ||
AC_CANONICAL_HOST | ||
case "$host_os" in | ||
@@ -22,6 +22,8 @@ | ||
AC_PROG_CPP | ||
AC_PROG_INSTALL | ||
|
||
+PKG_PROG_PKG_CONFIG() | ||
+ | ||
# Checks for header files. | ||
AC_HEADER_STDC | ||
AC_HEADER_TIME | ||
@@ -29,6 +31,7 @@ | ||
net/if_arp.h netinet/ether.h net/ethernet.h pthread.h], | ||
[], [AC_MSG_ERROR($ac_header not found)]) | ||
AC_CHECK_HEADERS([ncursesw/curses.h]) | ||
+PKG_CHECK_MODULES(ncurses,ncurses,LIBS="$LIBS $ncurses_LIBS",) | ||
|
||
# linux/if.h needs 'struct sockaddr' | ||
# linux/wireless.h in turn depends on linux/if.h | ||
--- a/Makefile.in 2017-07-14 21:35:18.154423280 +0300 | ||
+++ b/Makefile.in 2017-07-14 21:35:34.613402738 +0300 | ||
@@ -9,7 +9,7 @@ | ||
install-suid-root: exec_perms = 4755 | ||
|
||
CC ?= @CC@ | ||
-CFLAGS ?= @CFLAGS@ @LIBNL3_CFLAGS@ | ||
+CFLAGS = @CFLAGS@ @LIBNL3_CFLAGS@ | ||
CPPFLAGS ?= @CPPFLAGS@ | ||
LDFLAGS ?= @LDFLAGS@ | ||
DEFS ?= @DEFS@ | ||
@@ -25,8 +25,7 @@ | ||
DOCS = README.md NEWS THANKS AUTHORS COPYING ChangeLog | ||
|
||
%.o: %.c $(HEADERS) | ||
- @echo ' CC ' $< | ||
- @$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(DEFS) -c -o $@ $< | ||
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(DEFS) -c -o $@ $< | ||
|
||
all: @PACKAGE_NAME@ | ||
@PACKAGE_NAME@: $(MAIN) $(OBJS) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,54 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit autotools linux-info toolchain-funcs | ||
|
||
DESCRIPTION="Ncurses based monitor for IEEE 802.11 wireless LAN cards" | ||
HOMEPAGE="https://github.com/uoaerg/wavemon/" | ||
SRC_URI="https://github.com/uoaerg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86" | ||
|
||
IUSE="caps" | ||
RDEPEND="dev-libs/libnl:3 | ||
sys-libs/ncurses:0= | ||
caps? ( sys-libs/libcap )" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
|
||
DOCS=( README.md THANKS ) | ||
PATCHES=( | ||
"${FILESDIR}/${P}-build.patch" | ||
) | ||
|
||
pkg_pretend() { | ||
local CONFIG_CHECK="~CFG80211_WEXT" | ||
|
||
check_extra_config | ||
} | ||
|
||
src_prepare() { | ||
# Do not install docs to /usr/share | ||
sed -i -e '/^install:/s/install-docs//' Makefile.in || die \ | ||
'sed on Makefile.in failed' | ||
|
||
# automagic on libcap, discovered in bug #448406 | ||
use caps || export ac_cv_lib_cap_cap_get_flag=false | ||
|
||
# Respect CC | ||
tc-export CC | ||
|
||
default_src_prepare | ||
eautoreconf | ||
} | ||
|
||
src_install() { | ||
default_src_install | ||
# Install man files manually(bug #397807) | ||
doman wavemon.1 | ||
doman wavemonrc.5 | ||
} |