Skip to content

Commit

Permalink
dev-php/adodb: Version bump to 5.20.12
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.31, Repoman-2.3.9
  • Loading branch information
Brian Evans committed Apr 24, 2018
1 parent 93178a5 commit be3bcfc
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/adodb/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST adodb-5.20.12.tar.gz 464962 BLAKE2B 51b1bec4c9bda427988848cd0ff810058e159c75946ea4d14d1ab639545f0c95a8a1a2b8193c8c0403e37fc2e3b858f97b255b9b615b65786d1593269e9da731 SHA512 ac8f36dba459bac15f16ecfd1ece69edc922e67b6aec3641a0c8ffc50c6b1c437ecce2e5652c31f2e472f7abefb3ac5a8a2bef188959007442799784ab764c1e
DIST adodb-5.20.9.tar.gz 464257 BLAKE2B 38a37e4a5b1ac86b37cbd164c79e2112c78fb22530a225d2cac4f916703d4c2bd300a47a214344d8ae9e5c94467ec34cab96ab36a10ad8dad581ec74c73ae111 SHA512 bc40113012c27b759ff35e7395404d1756720e9daef7df4d33147b9950e9ffd032274ccd8808fe303ba75feeaf727e2deb50fc6d79826db96ce568a70007f30f
40 changes: 40 additions & 0 deletions dev-php/adodb/adodb-5.20.12.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

MY_PN="ADOdb"
DESCRIPTION="Database abstraction layer for PHP"
HOMEPAGE="https://github.com/ADOdb"
SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD LGPL-2.1+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""

# If you want to be picky, we should require that PHP be built with at
# least one database driver enabled; otherwise adodb isn't going to be
# able to do anything. But, the database USE flags for dev-lang/php are
# a mess. What we would *like* to do is have a set of USE flags for
# adodb that then propagate to PHP itself... for example, adodb[mysql]
# could require php[mysql]. To do that would require that we duplicate
# the database USE flag mess for adodb -- not desirable. Instead we punt
# and let the user install adodb unconditionally. If he doesn't have
# database support in PHP, it just won't work.
RDEPEND="dev-lang/php:*"

S="${WORKDIR}/${MY_PN}-${PV}"

src_install() {
DOCS="README.md docs/changelog*.md xmlschema*.dtd session/*.sql"
DOCS+=" session/*.txt session/*.xml pear/auth_adodb_example.php"
DOCS+=" pear/readme.Auth.txt"

dodoc $DOCS
rm -f $DOCS || die "failed to remove docs before installation"

insinto "/usr/share/php/${PN}"
doins *.php
doins -r contrib datadict drivers lang pear perf replicate session xsl
}

0 comments on commit be3bcfc

Please sign in to comment.