forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
net-im/signal-desktop-bin: add 7.13.0
Signed-off-by: Robert Siebeck <[email protected]> Signed-off-by: Viorel Munteanu <[email protected]>
- Loading branch information
Showing
2 changed files
with
97 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST signal-desktop_7.13.0_amd64.deb 120853554 BLAKE2B 7c9087d4d19944a73d8c0e113fcec5cebbc1c3a5788eb25f114479e010d2629a075b46eb7d74926d0af7d57a7540aeb067d6ebe496063d7e1c443b1e34ea2ec7 SHA512 390582ecf33e81343ce98f87e84c5ecbd6422e600553ebd5c358f9c4c7db7b7171796ccbaf9e0f656a9d02f0f28c97174eeaddb2d1688a25b6f01d7c5093ca2e | ||
DIST signal-desktop_7.8.0_amd64.deb 118931504 BLAKE2B 27e84bd8a305e0ca8cfdc0560d988e0f5aae4afb781b78d80e7749d742a44a9fbbaf7496c7e441ceacf948c258fc36c8cc453f04906055d8e3eca1bc8da4677f SHA512 2cb2813957f107384221daf1323c46a050e122293664c0f188e7e42c2f041c5827af4e3f6b78decace5dd8254268106157ff49dfcc63bec4dad10ef14fb6b66a |
96 changes: 96 additions & 0 deletions
96
net-im/signal-desktop-bin/signal-desktop-bin-7.13.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,96 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
MY_PN="${PN/-bin/}" | ||
|
||
inherit pax-utils unpacker xdg | ||
|
||
DESCRIPTION="Allows you to send and receive messages of Signal Messenger on your computer" | ||
HOMEPAGE="https://signal.org/ | ||
https://github.com/signalapp/Signal-Desktop" | ||
SRC_URI="https://updates.signal.org/desktop/apt/pool/s/${MY_PN}/${MY_PN}_${PV}_amd64.deb" | ||
S="${WORKDIR}" | ||
|
||
LICENSE="GPL-3 MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 ISC openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1" | ||
SLOT="0" | ||
KEYWORDS="-* amd64" | ||
IUSE="+sound" | ||
RESTRICT="splitdebug" | ||
|
||
RDEPEND=" | ||
>=app-accessibility/at-spi2-core-2.46.0:2 | ||
dev-libs/expat | ||
dev-libs/glib:2 | ||
dev-libs/nspr | ||
dev-libs/nss | ||
>=media-fonts/noto-emoji-20231130 | ||
media-libs/alsa-lib | ||
media-libs/mesa[X(+)] | ||
net-print/cups | ||
sys-apps/dbus[X] | ||
x11-libs/cairo | ||
x11-libs/gtk+:3[X] | ||
x11-libs/libdrm | ||
x11-libs/libX11 | ||
x11-libs/libxcb | ||
x11-libs/libxkbcommon | ||
x11-libs/libXcomposite | ||
x11-libs/libXdamage | ||
x11-libs/libXext | ||
x11-libs/libXfixes | ||
x11-libs/libXrandr | ||
x11-libs/pango | ||
sound? ( | ||
|| ( | ||
media-libs/libpulse | ||
media-sound/apulse | ||
) | ||
) | ||
" | ||
|
||
QA_PREBUILT=" | ||
opt/Signal/chrome_crashpad_handler | ||
opt/Signal/chrome-sandbox | ||
opt/Signal/libEGL.so | ||
opt/Signal/libGLESv2.so | ||
opt/Signal/libffmpeg.so | ||
opt/Signal/libvk_swiftshader.so | ||
opt/Signal/libvulkan.so.1 | ||
opt/Signal/resources/app.asar.unpacked/node_modules/* | ||
opt/Signal/signal-desktop | ||
opt/Signal/swiftshader/libEGL.so | ||
opt/Signal/swiftshader/libGLESv2.so" | ||
|
||
src_prepare() { | ||
default | ||
sed -e 's| --no-sandbox||g' \ | ||
-i usr/share/applications/signal-desktop.desktop || die | ||
unpack usr/share/doc/signal-desktop/changelog.gz | ||
} | ||
|
||
src_install() { | ||
insinto / | ||
dodoc changelog | ||
doins -r opt | ||
insinto /usr/share | ||
|
||
if has_version media-sound/apulse[-sdk] && ! has_version media-sound/pulseaudio; then | ||
sed -i 's/Exec=/Exec=apulse /g' usr/share/applications/signal-desktop.desktop || die | ||
fi | ||
|
||
doins -r usr/share/applications | ||
doins -r usr/share/icons | ||
fperms +x /opt/Signal/signal-desktop /opt/Signal/chrome-sandbox /opt/Signal/chrome_crashpad_handler | ||
fperms u+s /opt/Signal/chrome-sandbox | ||
pax-mark m opt/Signal/signal-desktop opt/Signal/chrome-sandbox opt/Signal/chrome_crashpad_handler | ||
|
||
dosym -r /opt/Signal/${MY_PN} /usr/bin/${MY_PN} | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_pkg_postinst | ||
elog "For using the tray icon on compatible desktop environments, start Signal with" | ||
elog " '--start-in-tray' or '--use-tray-icon'." | ||
} |