forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Michał Górny <[email protected]>
- Loading branch information
Showing
2 changed files
with
59 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST astroid-3.0.1.gh.tar.gz 461593 BLAKE2B de3458bcd9ba111020132e89b6e2fdf18b81b82cba68c986e84af91c910e6c70e7d13ff024b7947f3fa08e2491ba211a77a35421b3d5cd184b94e6a833c0da42 SHA512 2c8a4cf22959aef1eb9510430bcc55d00fcda76d022575786c9a59c093fe4196b67c0b9401f9226595a4cbf1fb9444bdfbb9ac2d83c115ec1d7d46cb7dd75dbd | ||
DIST astroid-3.0.2.gh.tar.gz 461786 BLAKE2B d005fe36e6d7dc4bfc7388f1d4ac52c4602f7c18accfacbeb55545b382fe5e16ef7cedd493aef5413b57a5ac872807b8d9857fc02a7b4053edd54780814f64e8 SHA512 88fa6ff9c66f5224113001c4911cbe2f3055b990c5d0b3ac206166575d7fd5b7fae99fa67a655703d7868ee8c47841ece8b2c2d44712b1fdaf39fa26f786815f |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,58 @@ | ||
# Copyright 1999-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
DISTUTILS_USE_PEP517=setuptools | ||
PYTHON_COMPAT=( pypy3 python3_{10..12} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Abstract Syntax Tree for logilab packages" | ||
HOMEPAGE=" | ||
https://github.com/pylint-dev/astroid/ | ||
https://pypi.org/project/astroid/ | ||
" | ||
SRC_URI=" | ||
https://github.com/pylint-dev/astroid/archive/v${PV}.tar.gz | ||
-> ${P}.gh.tar.gz | ||
" | ||
|
||
LICENSE="LGPL-2.1+" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86" | ||
|
||
# Version specified in pyproject.toml | ||
RDEPEND=" | ||
$(python_gen_cond_dep ' | ||
>=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}] | ||
' 3.10) | ||
" | ||
BDEPEND=" | ||
dev-python/setuptools-scm[${PYTHON_USEDEP}] | ||
test? ( | ||
dev-python/attrs[${PYTHON_USEDEP}] | ||
>=dev-python/numpy-1.17.0[${PYTHON_USEDEP}] | ||
dev-python/python-dateutil[${PYTHON_USEDEP}] | ||
dev-python/regex[${PYTHON_USEDEP}] | ||
) | ||
" | ||
|
||
distutils_enable_tests pytest | ||
|
||
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV} | ||
|
||
python_test() { | ||
local EPYTEST_DESELECT=( | ||
# no clue why they're broken | ||
tests/test_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part | ||
tests/test_regrtest.py::NonRegressionTests::test_numpy_distutils | ||
# pydantic-2? | ||
tests/brain/test_dataclasses.py::test_pydantic_field | ||
# requires urllib3 with bundled six (skipped with urllib3>=2) | ||
tests/test_modutils.py::test_file_info_from_modpath__SixMetaPathImporter | ||
) | ||
|
||
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 | ||
epytest | ||
} |