Skip to content

Commit

Permalink
dev-python/paramiko: version bump to 2.3.1
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Sep 26, 2017
1 parent f148535 commit be72695
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/paramiko/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST paramiko-1.16.0.tar.gz 1335094 SHA256 3297ebd3cd072f573772f7c7426939a443c62
DIST paramiko-2.1.2.tar.gz 1196746 SHA256 5fae49bed35e2e3d45c4f7b0db2d38b9ca626312d91119b3991d0ecf8125e310 SHA512 465c5381b1b0a472d2ad8e690f0916a5f51713880486c7b94cadcf85ea0a52569e18337ccfee5440869e4a0c76bd2b1bc15c414128c07326b40ecd36ea021466 WHIRLPOOL 39014f4ab316ccf13ce336a594befd00c68dd3eb371f9e29592ec32ee1afcc91ae9307b2c9ae4227569fbc5d5d2c639532cce4552780d4e35743cd5c834a28a3
DIST paramiko-2.2.1.tar.gz 1205818 SHA256 ff94ae65379914ec3c960de731381f49092057b6dd1d24d18842ead5a2eb2277 SHA512 6aa2cce301f32c15d66e2137bc8a5c10ea4a667c599b24047a1e176b10636fe3abd28c7b2974befdde432a86c924acceace056c0572ea3006d3e4a8160b725c3 WHIRLPOOL 90f7d92c2d19343ab4f1ce78284458892af332197192f9368d862aa8d759fdbf37faf14c83f5ffacad4b7228be697bf011bf11e23800d49c5b58eaf149d3e9ff
DIST paramiko-2.3.0.tar.gz 279279 SHA256 4c4bb490dc861c7f5e0b354c0cb7d51fcbef92fa6a7f3c855020e9bf2ca721fb SHA512 a7935b76805a938e389fcf38beca0eb653cc1bc370ed7869726361d5758235d282e747c42582781c122f7c8e4299e61292c1ac96dc3921d44aedaf8a699c1ebc WHIRLPOOL 335f7c127bf14d595c652b548ab0c10b263716d20099d7a1b5b6143e95d036a9fb8c85713e7d7131cfdff00dd2fdb6d620945fd70493bc1748279db3c8a9713e
DIST paramiko-2.3.1.tar.gz 282553 SHA256 3b50a5a2ce206cb540c27ce83245f565d0139104ee83af33f695db944c926166 SHA512 b63a177f1f03937d5650d6f2a3ca4c00e0c3ffb0080e5e5a8141aab435c3ad415f5af8c61cb2894d176544b854ff26ee510eaa41081b452dfa6213cdc0566665 WHIRLPOOL e86c29bf83554a54b7e2fbc4c45afac0da17c50769c230c8c9914f6bee472a8541f889dd8b7d63666a6ea45b90de44fbda34dd6764036c1c82643835624ce2cf
52 changes: 52 additions & 0 deletions dev-python/paramiko/paramiko-2.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
PYTHON_REQ_USE="threads(+)"

inherit distutils-r1

DESCRIPTION="SSH2 protocol library"
HOMEPAGE="http://www.paramiko.org/ https://github.com/paramiko/paramiko/ https://pypi.python.org/pypi/paramiko/"
# pypi tarballs are missing test data
#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
IUSE="doc examples"

RDEPEND="
>=dev-python/bcrypt-3.1.3[${PYTHON_USEDEP}]
>=dev-python/cryptography-1.5[${PYTHON_USEDEP}]
>=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
>=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
dev-python/setuptools[${PYTHON_USEDEP}]"

# Required for testsuite
DISTUTILS_IN_SOURCE_BUILD=1

python_test() {
"${PYTHON}" test.py --verbose || die "Tests fail with ${EPYTHON}"
}

python_compile_all() {
use doc && esetup.py build_sphinx -s sites/docs
}

python_install_all() {
use doc && local HTML_DOCS=( build/sphinx/html/. )

distutils-r1_python_install_all

if use examples; then
insinto /usr/share/doc/${PF}/examples
doins demos/*
fi
}

0 comments on commit be72695

Please sign in to comment.