Skip to content

Commit

Permalink
app-text/hunspell: add 1.7.1
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/866093
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Aug 23, 2022
1 parent fba2159 commit be7e4b5
Show file tree
Hide file tree
Showing 2 changed files with 83 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/hunspell/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST hunspell-1.7.0.tar.gz 482156 BLAKE2B daf689ab44872c78d27bd035d996c61da9b01b7bbe5ced120034b2d64bbead573ad3807dfe5a06ecdbd96c610f42e4ea015be4b2046ebafad13347c08e60913a SHA512 8149b2e8b703a0610c9ca5160c2dfad3cf3b85b16b3f0f5cfcb7ebb802473b2d499e8e2d0a637a97a37a24d62424e82d3880809210d3f043fa17a4970d47c903
DIST hunspell-1.7.1.tar.gz 526464 BLAKE2B fc657f2db789aba3a3888f95b28b03eecc1da85356717b527b53936cc167ccca86111f3ce24c23319f4d741f2d5a53eb492570a406279a08b947ddbd2c131be8 SHA512 472249309aecbbc58a025445781268867173e0651a6147f29644975ad65af043a1e2fbe91f2094934526889c7f9944739dc0a5f0d25328a77d22db1fd8f055ec
82 changes: 82 additions & 0 deletions app-text/hunspell/hunspell-1.7.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,82 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

LANGS="af bg ca cs cy da de de-1901 el en eo es et fo fr ga gl he hr hu ia id is
it kk km ku lt lv mi mk ms nb nl nn pl pt pt-BR ro ru sk sl sq sv sw tn uk zu"
inherit autotools flag-o-matic

DESCRIPTION="Spell checker, morphological analyzer library and command-line tool"
HOMEPAGE="https://hunspell.github.io/"
SRC_URI="https://github.com/hunspell/hunspell/releases/download/v${PV}/${P}.tar.gz"

LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
SLOT="0/$(ver_cut 1-2)"
IUSE="ncurses nls readline static-libs"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"

RDEPEND="
ncurses? ( sys-libs/ncurses:= )
readline? ( sys-libs/readline:= )
"
DEPEND="${RDEPEND}"
BDEPEND="sys-devel/gettext"

PDEPEND=""
for lang in ${LANGS}; do
IUSE+=" l10n_${lang}"
case ${lang} in
de-1901) dict="de_1901" ;;
pt-BR) dict="pt-br" ;;
*) dict="${lang}" ;;
esac
PDEPEND+=" l10n_${lang}? ( app-dicts/myspell-${dict} )"
done
unset dict lang LANGS

DOCS=( AUTHORS ChangeLog NEWS THANKS license.{hunspell,myspell} README.md )

PATCHES=(
# Upstream package creates some executables which names are too generic
# to be placed in /usr/bin - this patch prefixes them with 'hunspell-'.
# It modifies a Makefile.am file, hence eautoreconf.
"${FILESDIR}/${PN}-1.7.0-renameexes.patch"

"${FILESDIR}/${PN}-1.7.0-tinfo.patch" # bug #692614
)

src_prepare() {
default

eautoreconf
}

src_configure() {
# Missing somehow...
[[ ${CHOST} == *-darwin* ]] && append-libs -liconv

# I wanted to put the include files in /usr/include/hunspell.
# You can do that, libreoffice can find them anywhere, just
# ping me when you do so ; -- scarabeus
local myeconfargs=(
$(use_enable nls)
$(use_with ncurses ui)
$(use_with readline readline)
$(use_enable static-libs static)
)
econf "${myeconfargs[@]}"
}

src_install() {
default

einstalldocs

find "${ED}" -type f -name '*.la' -delete || die

# bug #342449
pushd "${ED}"/usr/$(get_libdir)/ >/dev/null || die
ln -s lib${PN}{-$(ver_cut 1).$(ver_cut 2).so.0.0.1,.so} || die
popd >/dev/null || die
}

0 comments on commit be7e4b5

Please sign in to comment.