Skip to content

Commit

Permalink
app-admin/pass: [QA] unconditionally install completion files
Browse files Browse the repository at this point in the history
QA policy [0] says that we don't conditionalise installation of
small files. It's a wasteful rebuild and inconsistent across packages
for when users desire completions to be available.

[0] https://projects.gentoo.org/qa/policy-guide/installed-files.html#pg0301
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Jul 31, 2021
1 parent f17fc82 commit be8b011
Show file tree
Hide file tree
Showing 4 changed files with 28 additions and 28 deletions.
3 changes: 0 additions & 3 deletions app-admin/pass/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -12,9 +12,6 @@
<flag name="git">
Use <pkg>dev-vcs/git</pkg> for password revisions.
</flag>
<flag name="fish-completion">
Enable fish completion support.
</flag>
<flag name="dmenu">
Add support for x11-misc/dmenu with the 'passmenu' program.
</flag>
Expand Down
Original file line number Diff line number Diff line change
@@ -1,18 +1,19 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit bash-completion-r1 elisp-common

DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely"
HOMEPAGE="https://www.passwordstore.org/"
SRC_URI="https://git.zx2c4.com/password-store/snapshot/password-store-${PV}.tar.xz"
S="${WORKDIR}/password-store-${PV}"

SLOT="0"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~ppc64 x86 ~x64-macos"
IUSE="+git X zsh-completion fish-completion emacs dmenu importers elibc_Darwin"
IUSE="+git X emacs dmenu importers elibc_Darwin"

RDEPEND="
app-crypt/gnupg
Expand All @@ -21,19 +22,16 @@ RDEPEND="
git? ( dev-vcs/git )
X? ( x11-misc/xclip )
elibc_Darwin? ( app-misc/getopt )
zsh-completion? ( app-shells/gentoo-zsh-completions )
fish-completion? ( app-shells/fish )
dmenu? ( x11-misc/dmenu x11-misc/xdotool )
emacs? ( >=app-editors/emacs-23.1:* >=app-emacs/f-0.11.0 >=app-emacs/s-1.9.0 >=app-emacs/with-editor-2.5.11 )
"

S="${WORKDIR}/password-store-${PV}"

src_prepare() {
default

use elibc_Darwin || return
# use coreutils'

# use coreutils
sed -i -e 's/openssl base64/base64/g' src/platform/darwin.sh || die
# host getopt isn't cool, and we aren't brew (rip out brew reference)
sed -i -e '/^GETOPT=/s/=.*$/=getopt-long/' src/platform/darwin.sh || die
Expand All @@ -51,13 +49,16 @@ src_install() {
PREFIX="${EPREFIX}/usr" \
BASHCOMPDIR="$(get_bashcompdir)" \
WITH_BASHCOMP=yes \
WITH_ZSHCOMP=$(usex zsh-completion) \
WITH_FISHCOMP=$(usex fish-completion)
WITH_ZSHCOMP=yes \
WITH_FISHCOMP=yes

use dmenu && dobin contrib/dmenu/passmenu

if use emacs; then
elisp-install ${PN} contrib/emacs/*.{el,elc}
elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
fi

if use importers; then
exeinto /usr/share/${PN}/importers
doexe contrib/importers/*
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -8,11 +8,12 @@ inherit bash-completion-r1 elisp-common
DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely"
HOMEPAGE="https://www.passwordstore.org/"
SRC_URI="https://git.zx2c4.com/password-store/snapshot/password-store-${PV}.tar.xz"
S="${WORKDIR}/password-store-${PV}"

SLOT="0"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
IUSE="+git wayland X zsh-completion fish-completion emacs dmenu importers elibc_Darwin"
IUSE="+git wayland X emacs dmenu importers elibc_Darwin"

RDEPEND="
app-crypt/gnupg
Expand All @@ -22,18 +23,15 @@ RDEPEND="
wayland? ( gui-apps/wl-clipboard )
X? ( x11-misc/xclip )
elibc_Darwin? ( app-misc/getopt )
zsh-completion? ( app-shells/gentoo-zsh-completions )
fish-completion? ( app-shells/fish )
dmenu? ( x11-misc/dmenu x11-misc/xdotool )
emacs? ( >=app-editors/emacs-23.1:* >=app-emacs/f-0.11.0 >=app-emacs/s-1.9.0 >=app-emacs/with-editor-2.5.11 )
"

S="${WORKDIR}/password-store-${PV}"

src_prepare() {
default

use elibc_Darwin || return

# use coreutils'
sed -i -e 's/openssl base64/base64/g' src/platform/darwin.sh || die
# host getopt isn't cool, and we aren't brew (rip out brew reference)
Expand All @@ -52,13 +50,16 @@ src_install() {
PREFIX="${EPREFIX}/usr" \
BASHCOMPDIR="$(get_bashcompdir)" \
WITH_BASHCOMP=yes \
WITH_ZSHCOMP=$(usex zsh-completion) \
WITH_FISHCOMP=$(usex fish-completion)
WITH_ZSHCOMP=yes \
WITH_FISHCOMP=yes

use dmenu && dobin contrib/dmenu/passmenu

if use emacs; then
elisp-install ${PN} contrib/emacs/*.{el,elc}
elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
fi

if use importers; then
exeinto /usr/share/${PN}/importers
doexe contrib/importers/*
Expand Down
15 changes: 8 additions & 7 deletions app-admin/pass/pass-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -10,16 +10,16 @@ if [[ ${PV} = 9999* ]]; then
inherit git-r3
else
SRC_URI="https://git.zx2c4.com/password-store/snapshot/password-store-${PV}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
S="${WORKDIR}/password-store-${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
fi

DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely"
HOMEPAGE="https://www.passwordstore.org/"

SLOT="0"
LICENSE="GPL-2"
IUSE="+git wayland X zsh-completion fish-completion emacs dmenu importers elibc_Darwin"
SLOT="0"
IUSE="+git wayland X emacs dmenu importers elibc_Darwin"

RDEPEND="
app-crypt/gnupg
Expand All @@ -29,8 +29,6 @@ RDEPEND="
wayland? ( gui-apps/wl-clipboard )
X? ( x11-misc/xclip )
elibc_Darwin? ( app-misc/getopt )
zsh-completion? ( app-shells/gentoo-zsh-completions )
fish-completion? ( app-shells/fish )
dmenu? ( x11-misc/dmenu x11-misc/xdotool )
emacs? ( >=app-editors/emacs-23.1:* >=app-emacs/f-0.11.0 >=app-emacs/s-1.9.0 >=app-emacs/with-editor-2.5.11 )
"
Expand All @@ -57,13 +55,16 @@ src_install() {
PREFIX="${EPREFIX}/usr" \
BASHCOMPDIR="$(get_bashcompdir)" \
WITH_BASHCOMP=yes \
WITH_ZSHCOMP=$(usex zsh-completion) \
WITH_FISHCOMP=$(usex fish-completion)
WITH_ZSHCOMP=yes \
WITH_FISHCOMP=yes

use dmenu && dobin contrib/dmenu/passmenu

if use emacs; then
elisp-install ${PN} contrib/emacs/*.{el,elc}
elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
fi

if use importers; then
exeinto /usr/share/${PN}/importers
doexe contrib/importers/*
Expand Down

0 comments on commit be8b011

Please sign in to comment.