forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
xfce-extra/xfce4-pulseaudio-plugin: bump to 0.3.2
Package-Manager: Portage-2.3.8, Repoman-2.3.3
- Loading branch information
Showing
2 changed files
with
61 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST xfce4-pulseaudio-plugin-0.2.4.tar.bz2 307315 SHA256 8d9330ddf1d44a864a36d566cce4b76d4f859c5984bba7653d7dc39aa24d5c3e SHA512 b53ab48e282a506fc7fe91fa70520f0db32f2f73653a0210681bf7389f13441d5af8f855604b59817b1fe7a3f41e2d4fe52b052ac0c3479f3f4e37b2afedb193 WHIRLPOOL 8763a9422a7519b5603703306d968f9e020c1bd4b304be0d21bd6353c54e8fa979ef68c513d6e1c398ce6857ad88807a7cb7eefc29d6fba4f12a243eb7205e26 | ||
DIST xfce4-pulseaudio-plugin-0.2.5.tar.bz2 351062 SHA256 087441331240f8fca6cbcc2839251ad7e8d624fed7b4b7b4cd4e6938cb26c0b2 SHA512 e56b9a6b33e5c82b8f665eee60a9b9ebcac3815cd60a2e576dd4c9a5a592fa4adc00c56be9ac5de07e13053455d7236759e468da8eca25a3c4638680f9474194 WHIRLPOOL c8f510ddbcabe9346d01c0dee6ceeb910e656637e4c5ca8a12ac4e3067a71596883a7654b8bfd4efa96404bd16f30180ba99988d0478b2d48504c686f720a520 | ||
DIST xfce4-pulseaudio-plugin-0.3.1.tar.bz2 395689 SHA256 61a39f892e5e06723a08f919682362ebaf54792ed1076f5be828d0209a52f482 SHA512 27802df660cfa9be43f10e8314259704bc0045c58d920553eb3eca665f2da35ec9055a616f2ad23f805c30c141b79bdfc955d0f1818db0d62be25d37965d5b09 WHIRLPOOL ec5c3a15c9afdaf2e789af93e6b0aac6ad060ff823be5953335cec25874b37a79ee0651525fcf27f8781b779fd0465e38ce2828393ca73371c16a7cd69ac7d8a | ||
DIST xfce4-pulseaudio-plugin-0.3.2.tar.bz2 396198 SHA256 fd4ae178912dc17ffb16ce887db24545624c7f423a02bd2eab47d52758fa99d8 SHA512 de24d19e2d757316666a8787f7534cad6331a74917e00fbd49740e514b5c5e223f0d1a84cea71a11312024f9baef8fc4b066abcb65538ebb95f1c297087279e1 WHIRLPOOL 85f093ace1fa5550d1acbeccbd033b167c13ede8a47f2b94ceb94642d09ea3905d3dd10341b9ebdf0c933fa799154db7f7e993dd89a6c5a638ecadd49f8ddba7 |
60 changes: 60 additions & 0 deletions
60
xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.3.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,60 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit gnome2-utils | ||
|
||
DESCRIPTION="A panel plug-in for PulseAudio volume control" | ||
HOMEPAGE="https://git.xfce.org/panel-plugins/xfce4-pulseaudio-plugin/" | ||
SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86" | ||
IUSE="debug keybinder libnotify" | ||
|
||
RDEPEND=">=dev-libs/glib-2.42.0:= | ||
media-sound/pulseaudio:= | ||
>=x11-libs/gtk+-3.20.0:3= | ||
>=xfce-base/libxfce4ui-4.11.0:=[gtk3(+)] | ||
>=xfce-base/libxfce4util-4.9.0:= | ||
>=xfce-base/xfce4-panel-4.11.0:= | ||
>=xfce-base/xfconf-4.6.0:= | ||
keybinder? ( dev-libs/keybinder:3= ) | ||
libnotify? ( x11-libs/libnotify:= )" | ||
DEPEND="${RDEPEND} | ||
dev-util/intltool | ||
virtual/pkgconfig" | ||
|
||
src_configure() { | ||
local myconf=( | ||
$(use_enable keybinder) | ||
$(use_enable libnotify) | ||
) | ||
|
||
econf "${myconf[@]}" | ||
} | ||
|
||
src_install() { | ||
default | ||
|
||
find "${D}" -name '*.la' -delete || die | ||
} | ||
|
||
pkg_postinst() { | ||
gnome2_icon_cache_update | ||
|
||
if ! has_version media-sound/pavucontrol; then | ||
elog "For the 'audio mixer...' shortcut to work, you need to install" | ||
elog "an external mixer application. Please either install:" | ||
elog | ||
elog " media-sound/pavucontrol" | ||
elog | ||
elog "or specify another application to use in the 'Properties' dialog." | ||
fi | ||
} | ||
|
||
pkg_postrm() { | ||
gnome2_icon_cache_update | ||
} |