Skip to content

Commit

Permalink
kde-frameworks/kio: Fix build with GCC-11
Browse files Browse the repository at this point in the history
Upstream commit 9965ec1b9e6f6db192a2355e4e3eb80bc27fc092

Thanks-to: Geoff Leach <[email protected]>
Closes: https://bugs.gentoo.org/766480
Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Jan 24, 2021
1 parent 6071f21 commit beabe66
Show file tree
Hide file tree
Showing 3 changed files with 43 additions and 6 deletions.
32 changes: 32 additions & 0 deletions kde-frameworks/kio/files/kio-5.77.0-gcc11.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
From 9965ec1b9e6f6db192a2355e4e3eb80bc27fc092 Mon Sep 17 00:00:00 2001
From: Ahmad Samir <[email protected]>
Date: Sun, 24 Jan 2021 11:10:27 +0200
Subject: [PATCH] Fix build with gcc11

Apparently now we need to #include <limit>.

Patch by Geoff Leach:
https://bugs.gentoo.org/766480
https://invent.kde.org/frameworks/kio/-/issues/3

NO_CHANGELOG
---
src/kntlm/des.cpp | 2 ++
1 file changed, 2 insertions(+)

diff --git a/src/kntlm/des.cpp b/src/kntlm/des.cpp
index 18d85bfd..65c86f06 100644
--- a/src/kntlm/des.cpp
+++ b/src/kntlm/des.cpp
@@ -29,6 +29,8 @@
#include <string.h>
#include <qendian.h>

+#include <limits>
+
static void permute_ip(unsigned char *inblock, DES_KEY *key, unsigned char *outblock);
static void permute_fp(unsigned char *inblock, DES_KEY *key, unsigned char *outblock);
static void perminit_ip(DES_KEY *key);
--
GitLab

11 changes: 7 additions & 4 deletions kde-frameworks/kio/kio-5.77.0-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -16,6 +16,9 @@ LICENSE="LGPL-2+"
KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
IUSE="acl +handbook kerberos +kwallet X"

# tests hang
RESTRICT+=" test"

RDEPEND="
dev-libs/libxml2
dev-libs/libxslt
Expand Down Expand Up @@ -68,10 +71,10 @@ PDEPEND="
>=kde-frameworks/kded-${PVCUT}:5
"

# tests hang
RESTRICT+=" test"

PATCHES=( "${FILESDIR}/${P}-crashfix.patch" )
PATCHES=(
"${FILESDIR}/${P}-crashfix.patch"
"${FILESDIR}/${P}-gcc11.patch" # bug 766480
)

src_configure() {
local mycmakeargs=(
Expand Down
6 changes: 4 additions & 2 deletions kde-frameworks/kio/kio-5.78.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -16,6 +16,9 @@ LICENSE="LGPL-2+"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
IUSE="acl +handbook kerberos +kwallet X"

# tests hang
RESTRICT+=" test"

RDEPEND="
dev-libs/libxml2
dev-libs/libxslt
Expand Down Expand Up @@ -68,8 +71,7 @@ PDEPEND="
>=kde-frameworks/kded-${PVCUT}:5
"

# tests hang
RESTRICT+=" test"
PATCHES=( "${FILESDIR}/${PN}-5.77.0-gcc11.patch" ) # bug 766480

src_configure() {
local mycmakeargs=(
Expand Down

0 comments on commit beabe66

Please sign in to comment.