Skip to content

Commit

Permalink
x11-wm/i3: Pump to v4.19.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.12, Repoman-3.0.2
Signed-off-by: Nelo-T. Wallus <[email protected]>
Closes: gentoo#19300
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
ntnn authored and Lars Wendler committed Feb 2, 2021
1 parent cb17331 commit bf574cb
Show file tree
Hide file tree
Showing 2 changed files with 105 additions and 0 deletions.
1 change: 1 addition & 0 deletions x11-wm/i3/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST i3-4.18.3.tar.bz2 1218766 BLAKE2B c394bbe9882dc893107f0c948632a3a79c52db75b75b2890f6f43fa60d80ce82d1c8a8c32a8793f59d9a6f929ab038765dbe3813c3c6bc1b79bebbbbde772451 SHA512 61599b79247ec546819bab22666a78fc8dc77eecbcf6055efb6b52720290fa7f72719ac6670396a6dfb54858781e438b5207c15fdf2cf9e2424a1b84ffeb749c
DIST i3-4.18.tar.bz2 1218591 BLAKE2B 582b7ba3a54edf8dd2657add05eb54a64b7c004761a1a248d91dfcb061cb9df215ff35301c125b11aa69b571daeacd5732b498934c1fb17f69404a101fd16ec8 SHA512 0bbfda7f4b20a92a50ffb6abbfc3f6bfe6bb4c987ad4b5b1791192eb23b8c3389cc9949a699901797370c14de1ff8e12447a3b8ce330ab7d300fafdb60a432ec
DIST i3-4.19.1.tar.xz 1277648 BLAKE2B a4d01d10c076da092faef2111ba0fadb481257c0011419cc911be0b63c0ff78053a39ff4a2887f6344794ea895190ebf1ac3585b598dbb90ff77d4de8fad7c53 SHA512 7a73d005e4ec438a7cf92ab719e17701948c5043cc431740b16e028e9771d1478fa539aebd1a8198fff6bec664f8bcecc17c3bd1ff35d53077d50d3ad1a8f7dc
DIST i3-4.19.tar.xz 1278600 BLAKE2B 3af5eac9cb618bc3b3da0bca430e1882701802f49e092d1e6fa7a35ceb3f2c0287b66eceeb0123a7dfda9976df06227bec34d7d98873aedc2292a2ba94584d84 SHA512 e9e85dfa099751e95f05e8ed5048535bc669d73c51d3bd7e83740ee79d613f981a1130c35f54fb4725b31d18bed63d6bd5efacce8e086483e28d7c778407653a
104 changes: 104 additions & 0 deletions x11-wm/i3/i3-4.19.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,104 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson optfeature virtualx
if [[ "${PV}" = *9999 ]]; then
inherit git-r3
fi

DESCRIPTION="An improved dynamic tiling window manager"
HOMEPAGE="https://i3wm.org/"
if [[ "${PV}" = *9999 ]]; then
EGIT_REPO_URI="https://github.com/i3/i3"
EGIT_BRANCH="next"
else
SRC_URI="https://i3wm.org/downloads/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi

LICENSE="BSD"
SLOT="0"
IUSE="doc test"

COMMON_DEPEND="dev-libs/libev
dev-libs/libpcre
dev-libs/yajl
x11-libs/libxcb[xkb]
x11-libs/libxkbcommon[X]
x11-libs/startup-notification
x11-libs/xcb-util
x11-libs/xcb-util-cursor
x11-libs/xcb-util-keysyms
x11-libs/xcb-util-wm
x11-libs/xcb-util-xrm
x11-misc/xkeyboard-config
x11-libs/cairo[X,xcb(+)]
x11-libs/pango[X]"
DEPEND="${COMMON_DEPEND}
test? (
dev-perl/AnyEvent
dev-perl/X11-XCB
dev-perl/Inline
dev-perl/Inline-C
dev-perl/IPC-Run
dev-perl/ExtUtils-PkgConfig
dev-perl/local-lib
virtual/perl-Test-Simple
x11-base/xorg-server[xephyr]
x11-misc/xvfb-run
)
doc? (
app-text/asciidoc
app-text/xmlto
dev-lang/perl
)"
RDEPEND="${COMMON_DEPEND}
dev-lang/perl
dev-perl/AnyEvent-I3
dev-perl/JSON-XS"
BDEPEND="virtual/pkgconfig"

PATCHES=(
"${FILESDIR}/${PN}-4.16-musl-GLOB_TILDE.patch"
)

src_prepare() {
default

cat <<- EOF > "${T}"/i3wm
#!/bin/sh
exec /usr/bin/i3
EOF
}

src_configure() {
local emesonargs=(
-Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
$(meson_use doc docs)
$(meson_use doc mans)
)

meson_src_configure
}

src_install() {
meson_src_install

exeinto /etc/X11/Sessions
doexe "${T}"/i3wm
}

src_test() {
virtx meson_src_test
}

pkg_postinst() {
elog "There are several packages that you may find useful with i3 and"
elog "their usage is suggested by the upstream maintainers."
elog "Uninstalled optional dependencies:"
optfeature "Application launcher" x11-misc/dmenu
optfeature "Simple screen locker" x11-misc/i3lock
optfeature "Status bar generator" x11-misc/i3status
}

0 comments on commit bf574cb

Please sign in to comment.