Skip to content

Commit

Permalink
app-backup/obnam: bump.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
robbat2 committed Jun 17, 2016
1 parent 4bbd405 commit bf5b441
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-backup/obnam/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST obnam-1.18.2.tar.gz 361576 SHA256 515aa3eaf9946f5f7beee1e3285d2822e67a43d209b34e57bf0e1ea809551895 SHA512 f375a3e8769775b2b3d5679d68d031f13d950ac6b2d50231b791f9625384f830ccaee3434f18eacdbc95ed6de2d1e4b33b1adac39ad8b8f96842ecc8e4664f91 WHIRLPOOL 17afe8d35f455decb0bcec3f1708e4f74cf6d14ee8a60bb6f9c53d17341d8d298d042c769571f458093d994053a5a293356716e423844c3bd69356ae4838cf73
DIST obnam-1.19.1.tar.gz 372739 SHA256 e4210d12e0126f14bc788ccb0c443362eb5f9419ab7ae84a22ff108d269e1819 SHA512 9ed9632eaa23fec5cc1fb39ea51825480cc9b39109fb3c7e6135ef90156d15e3555aaea910714ede94d93fc897ca04bfefae0487629fbf9fe149c5a0ddc74a5e WHIRLPOOL 04b1d072a31de70712438a2314e86c5cdd6c3bc49f655209876834e21f746770a63094a7d48b4be0e17ba928fb3b172787c31bb8dc17bea88d293ec631e6e0ab
DIST obnam-1.19.tar.gz 372386 SHA256 728629327fa3771e2046b926b025dcfdcbae33a77d946a4daed58b23f1f99153 SHA512 c0dfc8233a6b98d428475261d71b9878acf9bd0b7393ba50cd8c7ce6563ab4b92406c63a897d49b72b8506719e05631861f1fd7559164b13719ae7c76b800195 WHIRLPOOL f42920e3e9b322e4f7448d35035406fb35b7cfe4e91f302ea086f97f15b4c88a5d016e17855f7bff6d40250070f7e0428ecee52c47d63a90cefe9209922098a8
51 changes: 51 additions & 0 deletions app-backup/obnam/obnam-1.19.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"

inherit distutils-r1

DESCRIPTION="A backup program that supports encryption and deduplication"
HOMEPAGE="http://obnam.org/"
SRC_URI="http://git.liw.fi/cgi-bin/cgit/cgit.cgi/obnam/snapshot/${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="${PYTHON_DEPS}
dev-python/cliapp[${PYTHON_USEDEP}]
dev-python/fuse-python[${PYTHON_USEDEP}]
dev-python/larch[${PYTHON_USEDEP}]
dev-python/paramiko[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/tracing[${PYTHON_USEDEP}]
dev-python/ttystatus[${PYTHON_USEDEP}]
"
RDEPEND="${DEPEND}"

src_compile() {
addwrite /proc/self/comm
distutils-r1_src_compile
}

src_install() {
distutils-r1_src_install
find "${D}" -name "obnam-viewprof*" -delete
insinto /etc
doins "${FILESDIR}"/obnam.conf
keepdir /var/log/obnam
}

pkg_postinst() {
if [[ $REPLACING_VERSIONS < "1.2" ]]; then
elog "You will need to setup a config file before running obnam for the first time."
elog "For details, please see the obnam(1) manual page."
elog "An example file has been installed as /etc/obnam.conf for your convenience."
fi
}

0 comments on commit bf5b441

Please sign in to comment.