Skip to content

Commit

Permalink
dev-libs/quantlib: Version bump to 1.7.1
Browse files Browse the repository at this point in the history
Gentoo-Bug: 578872
* EAPI=6

Package-Manager: portage-2.2.28
  • Loading branch information
SoapGentoo committed Apr 2, 2016
1 parent 3666063 commit bf7e0b6
Show file tree
Hide file tree
Showing 2 changed files with 94 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/quantlib/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST QuantLib-1.6.tar.gz 8714267 SHA256 a135d424a59cbb00a75d7f7ac3a181d49e804abae1776b555ec0183e309f81ce SHA512 c38cc894873a36942c022c1d70eb7b0c5f2e9208ee9e949a656aef02fb9fe95436955b560b61188ea5a374f4b7674b46629178779e066135396f291788d772c4 WHIRLPOOL 5d94afd8f608ef81c207921f5b7b8237ea2eaca71844fe27206d4b0e7ed77e99d4c9e5c2e6c74649e82a95ca5d3fb8528e6c8ee929a849a7254cbee41ab9607e
DIST QuantLib-1.7.1.tar.gz 8715844 SHA256 b5dc38ae51ad7396ccf7358147753902838ce2870dd6e6a4d829c806db3e0a81 SHA512 8ba4fdb219b2886b448dbc6370ce6acec9f919a6baf7e8275a76ba13e0bf2d08cbb88cd5a3e450bcf379c17bd0492a9259483089de65e24b95d708f259bc30a7 WHIRLPOOL 3a32d47d81716f3a8fd1214f3be6554c00da2c828412feb46382b809a1f7a8046be9c790eaf8435451e0f503ef9771a5ce0e14effbe8d48c4f599dbc64bb1409
93 changes: 93 additions & 0 deletions dev-libs/quantlib/quantlib-1.7.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,93 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit elisp-common eutils toolchain-funcs

MY_P="QuantLib-${PV}"

DESCRIPTION="A comprehensive software framework for quantitative finance"
HOMEPAGE="http://quantlib.org/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug doc emacs examples openmp static-libs"

RDEPEND="dev-libs/boost:="
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )
emacs? ( virtual/emacs )"

DOCS="*.txt"

S="${WORKDIR}/${MY_P}"

SITEFILE="50${PN}-gentoo.el"

pkg_setup() {
if use openmp ; then
tc-has-openmp || die "Please switch to an openmp compatible compiler"
fi
}

src_configure() {
# NOTE: Too fragile for single .pdf or .ps document
local prog
for prog in DVIPS LATEX MAKEINDEX PDFLATEX; do
export ac_cv_path_${prog}=no
done

use doc || export ac_cv_path_DOXYGEN=no
use emacs || export ac_cv_prog_EMACS=no

# NOTE: --enable-examples will only change noinst_PROGRAMS to bin_PROGRAMS
econf \
$(use_enable debug error-functions) \
$(use_enable debug error-lines) \
$(use_enable debug tracing) \
$(use_enable openmp) \
$(use_enable static-libs static) \
--enable-examples \
--with-lispdir="${SITELISP}/${PN}"
}

src_compile() {
default

if use doc; then
pushd Docs >/dev/null
emake docs-html
popd >/dev/null
fi
}

src_install(){
default
prune_libtool_files

if use doc; then
find Docs \( -name '.time-stamp*' -o -name '*.doxy' -o -name 'Makefile*' \) -delete || die
dodoc -r Docs
fi

if use examples; then
find Examples -name '.libs' -exec rm -rf {} + || die
find Examples \( -name '*vc*proj*' -o -name '*.dev' -o -name 'Makefile*' -o -name '*.o' \) -delete || die
insinto "/usr/share/doc/${PF}"
doins -r Examples
fi

use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
}

pkg_postinst() {
use emacs && elisp-site-regen
}

pkg_postrm() {
use emacs && elisp-site-regen
}

0 comments on commit bf7e0b6

Please sign in to comment.