Skip to content

Commit

Permalink
x11-wm/lumina: bump to 1.5.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Andrey Grozin <[email protected]>
  • Loading branch information
Andrey Grozin committed Jun 19, 2019
1 parent d884e0d commit bf961fd
Show file tree
Hide file tree
Showing 2 changed files with 92 additions and 0 deletions.
1 change: 1 addition & 0 deletions x11-wm/lumina/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST lumina-1.3.0_p1.tar.gz 86451718 BLAKE2B 7834fad1541144524fc44d5e2cc1af21e82878c05f0cc2da4cf90f8f7e51614f535bab1bcb81c6d5929e14b2fa7ba7df8e66e53a9a81b55c973511f3b3e7cc17 SHA512 93fb195f26984a2ba6e62dbe1ea619e4ab8e936d1cf1d335db8a7e51058c9be8d3e389146259f8229fb5dc6477610dcc2e1278c4e2a348f27904a318ba095707
DIST lumina-1.4.0_p1.tar.gz 22489599 BLAKE2B 0c183763dae0ca046fa5d1cebc184a7ba5987113a12f72285e5dabfe25ca763683a23cb76889673ac3c2817feb2233e8b7da9fefed41040f91b0bb01d8ce03ae SHA512 340079832f4f6c9c9c70f11d7743b7c7db6772897f6411a966bf2bd77124bab1fbac8f5751164fb8a08a12c4443f515aaee76b117b4f959263eeaa98dbcbe41e
DIST lumina-1.5.0.tar.gz 20657364 BLAKE2B 62b064e1be3ce69c078e68524e011a8ce4d61c680a4732da7992a7b72833363fceb0a0895a228ec9de7921d989253c70c518810b91c23226aded1f54b23b1aea SHA512 37106d71a9ba7188c4ded0614d2d4424f732519e11288ae312dfcd9a0b5b26dd31dfa812e74a96c0e3e0fb99fae4dc00806fd7a24183746688c72d997054af7d
91 changes: 91 additions & 0 deletions x11-wm/lumina/lumina-1.5.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,91 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PLOCALES="af ar az bg bn bs ca cs cy da de el en_AU en_GB en_ZA es et eu fa fi fr fr_CA fur gl he hi hr hu id is it ja ka ko lt lv mk mn ms mt nb ne nl pa pl pt pt_BR ro ru sa sk sl sr sv sw ta tg th tr uk ur uz vi zh_CN zh_HK zh_TW zu"

inherit qmake-utils l10n xdg-utils
DESCRIPTION="Lumina desktop environment"
HOMEPAGE="https://lumina-desktop.org/"
SRC_URI="https://github.com/trueos/${PN}/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="desktop-utils"

COMMON_DEPEND="dev-qt/qtcore:5
dev-qt/qtconcurrent:5
dev-qt/qtmultimedia:5[widgets]
dev-qt/qtsvg:5
dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
dev-qt/qtgui:5
dev-qt/qtdeclarative:5
dev-qt/qtprintsupport:5
x11-libs/libxcb:0
x11-libs/xcb-util
x11-libs/xcb-util-image
x11-libs/xcb-util-wm
desktop-utils? ( app-text/poppler[qt5] )"

DEPEND="$COMMON_DEPEND
dev-qt/linguist-tools:5"

RDEPEND="$COMMON_DEPEND
sys-fs/inotify-tools
x11-misc/numlockx
x11-wm/fluxbox
|| ( x11-apps/xbacklight
sys-power/acpilight )
media-sound/alsa-utils
sys-power/acpi
app-admin/sysstat"

S="${WORKDIR}/${P/_/-}"

PATCHES=(
"${FILESDIR}/1.2.0-desktop-files.patch"
)

DOCS=( README.md )

src_prepare(){
default

if use !desktop-utils ; then
rm -rf src-qt5/desktop-utils || die
sed -e "/desktop-utils/d" -i src-qt5/src-qt5.pro || die
fi

l10n_find_plocales_changes "${S}/src-qt5/core/${PN}-desktop/i18n" "${PN}-desktop_" '.ts'
}

src_configure(){
eqmake5 PREFIX="${EPREFIX}/usr" LIBPREFIX="${EPREFIX}/usr/$(get_libdir)" \
CONFIG+=WITH_I18N QMAKE_CFLAGS_ISYSTEM=
}

src_install(){
emake install INSTALL_ROOT="${D}"
einstalldocs

remove_locale() {
rm -f "${ED%/}"/usr/share/${PN}-desktop/i18n/l*_${1}.qm

}
l10n_for_each_disabled_locale_do remove_locale
}

pkg_postinst() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
xdg_icon_cache_update
}

pkg_postrm() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
xdg_icon_cache_update
}

0 comments on commit bf961fd

Please sign in to comment.