forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.2.28
- Loading branch information
Showing
4 changed files
with
54 additions
and
3 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST nmapsi4-0.4.1.tar.xz 3139252 SHA256 45482842f414179eb1a9ea0ae88fe4a43d59a54341b97a82be605b43cec41c9a SHA512 243e241a80069d9a7ff7c38c6ed12656385f13250ff707ff84f569807916aab11f14c784210d8cb3047519d80691f5068563c50dac18d74ec9bda8c3f320e802 WHIRLPOOL 99fb464e124ed7fbe2822395cf992aa0bdb49a889cdb855a3a7d03c8da394c3c4e5aadd2aeb2ef08c4383fa3ac396c37a7c26798869e455237e0d8d5e5b23ccc | ||
DIST nmapsi4-0.5-alpha1.tar.xz 3163140 SHA256 3aff1a8c77e3787ff101b33a39e1b584b092fb8b4c5347d61b32562be85069a3 SHA512 fa4e604aeb6b342dec7e3fc85d83eda04385bd49a8d53b88e1eec2878c2c3410575a3ae59c59e6cd8e2b9f83de204f895a128d1cf3e7cccbd6bd7b78abd7dcfb WHIRLPOOL a694dd622a4fa2f224c63d5a0e96dd7c8629c3bdbf2bd9fd90c8ee1b71bd33305a708c219bbce9ea774db41c9e9a351f6631d0e88f8f73d29e8a2001be81467a |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,50 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
PLOCALES="ca cs de es fr it ru" | ||
|
||
inherit cmake-utils l10n | ||
|
||
MY_P=${PN}4-${PV/_/-} | ||
|
||
DESCRIPTION="A Qt frontend to nmap" | ||
HOMEPAGE="http://www.nmapsi4.org/" | ||
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
CDEPEND=" | ||
dev-qt/qtcore:5 | ||
dev-qt/qtdbus:5 | ||
dev-qt/qtdeclarative:5 | ||
dev-qt/qtgui:5 | ||
dev-qt/qtnetwork:5 | ||
dev-qt/qtscript:5 | ||
dev-qt/qtwebkit:5 | ||
dev-qt/qtwidgets:5 | ||
" | ||
DEPEND="${CDEPEND} | ||
dev-qt/linguist-tools:5 | ||
" | ||
RDEPEND="${CDEPEND} | ||
net-analyzer/nmap | ||
net-dns/bind-tools | ||
" | ||
|
||
S=${WORKDIR}/${MY_P} | ||
|
||
DOCS=( AUTHORS HACKING README.md TODO Translation ) | ||
|
||
nmapsi_disable_locale() { | ||
sed -i -e "/ts\/${PN}4_${1}\.ts/d" src/CMakeLists.txt || die | ||
} | ||
|
||
src_prepare() { | ||
l10n_for_each_disabled_locale_do nmapsi_disable_locale | ||
cmake-utils_src_prepare | ||
} |