Skip to content

Commit

Permalink
dev-embedded/xa: add 2.3.14
Browse files Browse the repository at this point in the history
Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
ionenwks committed Feb 8, 2023
1 parent cddffad commit bfe65ba
Show file tree
Hide file tree
Showing 3 changed files with 92 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-embedded/xa/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST xa-2.3.13.tar.gz 155606 BLAKE2B 8196f8f88bee29dbab9ad026c0d4e3519159c4ed7579dc7db391c0bdd7b1bfe31e2884644258d863e299ac3b5fcc43718b3d95b9b7d7802541a9d58366728ffe SHA512 b8a4c1856e51bbe212b98be06895987d6fb926a229511a67ea90a934da1fcc84daf29bd289c3c4c2254d2bce345333bb92747947f3286376761613b2e181e99b
DIST xa-2.3.14.tar.gz 156876 BLAKE2B 3dd4f369d69cd85c7c545e4aba7698deb9402946c755ac2709c43cb4a795d1cde730286a4a0df2615c39367443788cd4314bf526def863fa57bc85d36ca2dc60 SHA512 71d4631cb3e698b6522ca76c4b34078ded0632533bdaaa8b8d584eb27f0958ed288a6765136ff0ad03cd861a2dccbb76c6d8db0abf277a61ae864ad23212653d
60 changes: 60 additions & 0 deletions dev-embedded/xa/files/xa-2.3.14-make.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
https://bugs.gentoo.org/722600
--- a/Makefile
+++ b/Makefile
@@ -2,4 +2,2 @@
#
-CC = gcc
-LD = gcc
# for testing. not to be used; build failures in misc/.
@@ -7,4 +5,2 @@
#CFLAGS = -O2 -g
-CFLAGS = -O2
-LDFLAGS = -lc

@@ -37,9 +33,9 @@
xa:
- (cd src && LD=${LD} CC="${CC} ${CFLAGS}" ${MAKE})
+ (cd src && ${MAKE})

load:
- (cd loader && CC="${CC} ${CFLAGS}" ${MAKE})
+ (cd loader && ${MAKE})

uncpk:
- (cd misc && CC="${CC} ${CFLAGS}" ${MAKE})
+ (cd misc && ${MAKE})

--- a/misc/Makefile
+++ b/misc/Makefile
@@ -4,3 +4,2 @@
# -Wall -ansi et al. cause compile problems.
-CFLAGS = -O2

@@ -12,15 +11,15 @@
../uncpk: uncpk.c
- ${CC} ${CFLAGS} uncpk.c -o $(XCBMLIB)/uncpk
+ ${CC} ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} uncpk.c -o $(XCBMLIB)/uncpk

../printcbm: printcbm.c
- ${CC} ${CFLAGS} printcbm.c -o $(XCBMLIB)/printcbm
+ ${CC} ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} printcbm.c -o $(XCBMLIB)/printcbm

../file65: file65.c
- ${CC} ${CFLAGS} file65.c -o $(XCBMLIB)/file65
+ ${CC} ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} file65.c -o $(XCBMLIB)/file65

../ldo65: ldo65.c
- ${CC} ${CFLAGS} ldo65.c -o $(XCBMLIB)/ldo65
+ ${CC} ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} ldo65.c -o $(XCBMLIB)/ldo65

../reloc65: reloc65.c
- ${CC} ${CFLAGS} reloc65.c -o $(XCBMLIB)/reloc65
+ ${CC} ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} reloc65.c -o $(XCBMLIB)/reloc65

--- a/src/Makefile
+++ b/src/Makefile
@@ -10,3 +10,3 @@
xa: ${OBJ}
- ${LD} -o ../xa ${OBJ} ${LDFLAGS}
+ ${CC} ${LDFLAGS} -o ../xa ${OBJ}

31 changes: 31 additions & 0 deletions dev-embedded/xa/xa-2.3.14.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit toolchain-funcs

DESCRIPTION="High-speed, two-pass portable 6502 cross-assembler"
HOMEPAGE="https://www.floodgap.com/retrotech/xa/"
SRC_URI="https://www.floodgap.com/retrotech/xa/dists/${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"

PATCHES=(
"${FILESDIR}"/${PN}-2.3.14-make.patch
)

src_configure() {
tc-export CC
}

src_test() {
emake -j1 test
}

src_install() {
emake DESTDIR="${ED}"/usr install
einstalldocs
}

0 comments on commit bfe65ba

Please sign in to comment.