forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
kde-misc/tellico: 3.1.3 version bump
Signed-off-by: Andreas Sturmlechner <[email protected]> Package-Manager: Portage-2.3.51, Repoman-2.3.11
- Loading branch information
Showing
4 changed files
with
160 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST tellico-3.1.2.tar.xz 4591752 BLAKE2B 9601fa35c068d7c961bef1235cb65609b8c148b64a72771817ac16e3662ebdc35ed9b53944fe1d30c62732f2861e5a668907cc3ea9dc9f682c9e2336b12bea22 SHA512 e86966636123db813f33ad90197950e1afb38d4096e15c785a9d9f2b846872d254cbdaeec7528a13627bf8edc63d409a42fbb35172949b9b45d6a4b5c40ac28f | ||
DIST tellico-3.1.3.tar.xz 4607668 BLAKE2B 4c4fb678b16611c448e0fc77f0b5c9e03f344c76d20e6006c03ee12140b647fefa7a3aba2f5312ea8c36f3722418981fb469a6c199f1e115542c784003854d28 SHA512 9024f423f0685e834ed46e7038c5b95fab5b684aaac00d6298e23493fb4290daeda994faf36a0f04973093a477be5506591e6b0e7f57ef5591fb10953ad8ec5e |
44 changes: 44 additions & 0 deletions
44
kde-misc/tellico/files/tellico-3.1.3-regexp-filtering.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,44 @@ | ||
From 47f19fac2fdbbf5c5b5124883043e473f8c44edd Mon Sep 17 00:00:00 2001 | ||
From: Robby Stephenson <[email protected]> | ||
Date: Tue, 2 Oct 2018 21:02:37 -0400 | ||
Subject: Fix bug when using regexp filter for number fields | ||
|
||
Only use a QIntValidator when the filter rule is not a regular | ||
expression. | ||
|
||
BUG: 399323 | ||
FIXED-IN: 3.1.4 | ||
FIXED-IN: 3.2 | ||
--- | ||
ChangeLog | 4 ++++ | ||
src/gui/filterrulewidget.cpp | 3 ++- | ||
2 files changed, 6 insertions(+), 1 deletion(-) | ||
|
||
diff --git a/ChangeLog b/ChangeLog | ||
index 879f4d0..3284dc7 100644 | ||
--- a/ChangeLog | ||
+++ b/ChangeLog | ||
@@ -1,3 +1,7 @@ | ||
+2018-10-02 Robby Stephenson <[email protected]> | ||
+ | ||
+ * Fixed bug when using a regular expression for filtering in a number field (Bug 399323). | ||
+ | ||
2018-09-02 Robby Stephenson <[email protected]> | ||
|
||
* Released Tellico 3.1.3. | ||
diff --git a/src/gui/filterrulewidget.cpp b/src/gui/filterrulewidget.cpp | ||
index 8e3d7b1..aa3718d 100644 | ||
--- a/src/gui/filterrulewidget.cpp | ||
+++ b/src/gui/filterrulewidget.cpp | ||
@@ -169,7 +169,8 @@ void FilterRuleWidget::slotRuleFunctionChanged(int which_) { | ||
} else { | ||
m_valueStack->setCurrentWidget(m_ruleValue); | ||
m_ruleValue->setPlaceholderText(QString()); | ||
- if(m_ruleType == Number) { | ||
+ if(m_ruleType == Number && | ||
+ (data != FilterRule::FuncRegExp && data != FilterRule::FuncNotRegExp)) { | ||
m_ruleValue->setValidator(new QIntValidator(this)); | ||
} else { | ||
m_ruleValue->setValidator(nullptr); | ||
-- | ||
cgit v0.11.2 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,24 @@ | ||
From 1aa87a1c1538a0103a1624c663606b8d47566f42 Mon Sep 17 00:00:00 2001 | ||
From: Robby Stephenson <[email protected]> | ||
Date: Mon, 3 Sep 2018 08:39:49 -0400 | ||
Subject: Correctly set version number | ||
|
||
--- | ||
CMakeLists.txt | 2 +- | ||
1 file changed, 1 insertion(+), 1 deletion(-) | ||
|
||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index 214e2ca..817750b 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -2,7 +2,7 @@ | ||
cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR) | ||
|
||
project(Tellico) | ||
-set(TELLICO_VERSION "3.1.2+git") | ||
+set(TELLICO_VERSION "3.1.3") | ||
|
||
set(QT_MIN_VERSION "5.4.0") | ||
|
||
-- | ||
cgit v0.11.2 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,91 @@ | ||
# Copyright 1999-2018 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
KDE_HANDBOOK="forceoptional" | ||
KDE_TEST="forceoptional" | ||
VIRTUALX_REQUIRED="test" | ||
inherit kde5 | ||
|
||
DESCRIPTION="Collection manager based on KDE Frameworks" | ||
HOMEPAGE="http://tellico-project.org/" | ||
SRC_URI="http://tellico-project.org/files/${P}.tar.xz" | ||
|
||
LICENSE="|| ( GPL-2 GPL-3 )" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="cddb discid pdf scanner semantic-desktop taglib v4l xmp yaz" | ||
|
||
RDEPEND=" | ||
$(add_frameworks_dep karchive) | ||
$(add_frameworks_dep kcodecs) | ||
$(add_frameworks_dep kcompletion) | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kconfigwidgets) | ||
$(add_frameworks_dep kcoreaddons) | ||
$(add_frameworks_dep kcrash) | ||
$(add_frameworks_dep kguiaddons) | ||
$(add_frameworks_dep khtml) | ||
$(add_frameworks_dep kiconthemes) | ||
$(add_frameworks_dep kitemmodels) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep kjobwidgets) | ||
$(add_frameworks_dep kio) | ||
$(add_frameworks_dep knewstuff) | ||
$(add_frameworks_dep kparts) | ||
$(add_frameworks_dep kservice) | ||
$(add_frameworks_dep ktextwidgets) | ||
$(add_frameworks_dep kwallet) | ||
$(add_frameworks_dep kwidgetsaddons) | ||
$(add_frameworks_dep kwindowsystem) | ||
$(add_frameworks_dep kxmlgui) | ||
$(add_frameworks_dep solid) | ||
$(add_frameworks_dep sonnet) | ||
$(add_qt_dep qtdbus) | ||
$(add_qt_dep qtgui) | ||
$(add_qt_dep qtnetwork) | ||
$(add_qt_dep qtwidgets) | ||
$(add_qt_dep qtxml) | ||
>=dev-perl/Text-BibTeX-0.780.0-r1 | ||
dev-libs/libxml2 | ||
dev-libs/libxslt | ||
cddb? ( $(add_kdeapps_dep libkcddb) ) | ||
discid? ( dev-libs/libcdio:= ) | ||
pdf? ( app-text/poppler[qt5] ) | ||
scanner? ( $(add_kdeapps_dep libksane) ) | ||
semantic-desktop? ( $(add_frameworks_dep kfilemetadata) ) | ||
taglib? ( >=media-libs/taglib-1.5 ) | ||
v4l? ( >=media-libs/libv4l-0.8.3 ) | ||
xmp? ( >=media-libs/exempi-2 ) | ||
yaz? ( >=dev-libs/yaz-2:0 ) | ||
" | ||
DEPEND="${RDEPEND} | ||
sys-devel/gettext | ||
" | ||
|
||
# tests need network access | ||
RESTRICT="test" | ||
|
||
DOCS=( AUTHORS ChangeLog README ) | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${P}-version.patch" | ||
"${FILESDIR}/${P}-regexp-filtering.patch" | ||
) | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DCMAKE_DISABLE_FIND_PACKAGE_Csv=ON | ||
$(cmake-utils_use_find_package cddb KF5Cddb) | ||
$(cmake-utils_use_find_package discid CDIO) | ||
$(cmake-utils_use_find_package pdf Poppler) | ||
$(cmake-utils_use_find_package scanner KF5Sane) | ||
$(cmake-utils_use_find_package semantic-desktop KF5FileMetaData) | ||
$(cmake-utils_use_find_package taglib Taglib) | ||
-DENABLE_WEBCAM=$(usex v4l) | ||
$(cmake-utils_use_find_package xmp Exempi) | ||
$(cmake-utils_use_find_package yaz Yaz) | ||
) | ||
|
||
kde5_src_configure | ||
} |