forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/pycharm-community: Require Java 1.8
Package-Manager: portage-2.2.28
- Loading branch information
Showing
1 changed file
with
38 additions
and
0 deletions.
There are no files selected for viewing
38 changes: 38 additions & 0 deletions
38
dev-util/pycharm-community/pycharm-community-2016.1-r1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
inherit eutils readme.gentoo | ||
|
||
DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis" | ||
HOMEPAGE="http://www.jetbrains.com/pycharm/" | ||
SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
IUSE="" | ||
|
||
RDEPEND=">=virtual/jre-1.8" | ||
DEPEND="" | ||
|
||
RESTRICT="mirror strip" | ||
QA_PREBUILT="/opt/${PN}/bin/fsnotifier | ||
/opt/${PN}/bin/fsnotifier64" | ||
|
||
MY_PN=${PN/-community/} | ||
|
||
src_install() { | ||
insinto /opt/${PN} | ||
doins -r * | ||
|
||
fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh} | ||
|
||
dosym /opt/${PN}/bin/pycharm.sh /usr/bin/${PN} | ||
newicon "bin/${MY_PN}.png" ${PN}.png | ||
make_desktop_entry ${PN} "${PN}" "${PN}" | ||
|
||
readme.gentoo_src_install | ||
} |