forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
net-misc/whois: Bump to version 5.3.1
Package-Manager: Portage-2.3.38, Repoman-2.3.9
- Loading branch information
Lars Wendler
committed
May 22, 2018
1 parent
d4cc98e
commit c0a0ffe
Showing
2 changed files
with
66 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST whois_5.2.12.tar.xz 80428 BLAKE2B 53aa08d4e45ab417585aaaff03beb588a01e88c35d508f96e0738e6934659df6ab78c21d5794d86ce90c775fe5a32242710e8cf93b9f46c52dc32597ad113f40 SHA512 df40e2e7cbd11d00984f865e122ad4ece882a6a45e2f75ad5ea24ce937b7e9452b01fd886f43bae55fd065a6556cfc4577e7126151b5fd43fa806c4b0c886ced | ||
DIST whois_5.2.20.tar.xz 82336 BLAKE2B b10d7e22f41bfb68cdd1264016bbfeeb93436a5c46b0ddcfc79834d0446ea8c21cd8ff95bc440bbe4fda0d5b08a16c50fe9504c98c3de3cf4ce18892203518e1 SHA512 3308d9f5562babe007e46b7764718f13c1e7cd8ef7f501161353e4b1b81efacec9742ec25dec3b1cc80940898c785c1920a1aa68af10081f952ebde320075808 | ||
DIST whois_5.3.0.tar.xz 82728 BLAKE2B ac5e9bdd070c3a79306f79709d6450455ff74fc7c3a8c81380f79b98cdd36d25932032673710a39ec55da2220f1d0a21221e1a2b70c36e8798affe9b7f46f3bb SHA512 a507f38254d826a9112d1f5a7888fbd4b79eeaa372977c02e4e8235509d133540ba647ddece95376f6ac704f9b1042d276051d4a3a36d10906ad11f69561432f | ||
DIST whois_5.3.1.tar.xz 82920 BLAKE2B b4e58ae3f58c8e5de8bca5be3c0e753e0de91651bea1aa4789d389bc65e5155cddb1e87a2adc39340f33360533ef2b86eb9b7b13116a2d64e8a68496529e65e5 SHA512 4840ceecaef1d47bda436f8de8b539ff2b1446dd99ec0867d0bb2b478c13fac190a4a265ab31abb30a779f1a221062f298cd01a1b19ce873221b39dbd3a4a3d7 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,65 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit toolchain-funcs | ||
|
||
MY_P="${P/-/_}" | ||
DESCRIPTION="improved Whois Client" | ||
HOMEPAGE="https://www.linux.it/~md/software/" | ||
SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.xz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux" | ||
IUSE="iconv idn nls" | ||
RESTRICT="test" #59327 | ||
|
||
RDEPEND="iconv? ( virtual/libiconv ) | ||
idn? ( net-dns/libidn2 ) | ||
nls? ( virtual/libintl )" | ||
DEPEND="${RDEPEND} | ||
app-arch/xz-utils | ||
>=dev-lang/perl-5 | ||
virtual/pkgconfig | ||
nls? ( sys-devel/gettext )" | ||
|
||
PATCHES=( | ||
"${FILESDIR}"/${PN}-4.7.2-config-file.patch | ||
"${FILESDIR}"/${PN}-5.3.0-libidn_automagic.patch | ||
) | ||
|
||
src_prepare() { | ||
default | ||
if use nls ; then | ||
sed -i -e 's:#\(.*pos\):\1:' Makefile || die | ||
else | ||
sed -i -e '/ENABLE_NLS/s:define:undef:' config.h || die | ||
|
||
# don't generate po files when nls is disabled (bug #419889) | ||
sed -i -e '/^all:/s/ pos//' \ | ||
-e '/^install:/s/ install-pos//' Makefile || die | ||
fi | ||
} | ||
|
||
src_configure() { :; } # expected no-op | ||
|
||
src_compile() { | ||
unset HAVE_ICONV HAVE_LIBIDN | ||
use iconv && export HAVE_ICONV=1 | ||
use idn && export HAVE_LIBIDN=1 | ||
tc-export CC | ||
emake CFLAGS="${CFLAGS} ${CPPFLAGS}" | ||
} | ||
|
||
src_install() { | ||
emake BASEDIR="${ED}" prefix=/usr install | ||
insinto /etc | ||
doins whois.conf | ||
dodoc README debian/changelog | ||
|
||
if [[ ${USERLAND} != "GNU" ]]; then | ||
mv "${ED%/}"/usr/share/man/man1/{whois,mdwhois}.1 || die | ||
mv "${ED%/}"/usr/bin/{whois,mdwhois} || die | ||
fi | ||
} |