Skip to content

Commit

Permalink
dev-python/versioneer: Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0_rc1
  • Loading branch information
patricklauer committed Jun 12, 2016
1 parent f20920f commit c0c66fe
Show file tree
Hide file tree
Showing 2 changed files with 31 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/versioneer/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST versioneer-0.15.tar.gz 35408 SHA256 1252b9b9420fc3bc01036640da7928fe5d04519f463c5e960eb774c3ea80cd09 SHA512 b9d2f282f5dc681b0dafb0ae34352eb995e16b3184047bc29301b52acde9fc29b49e129c49c767827808a1e524315ece8c8fe02edf18a9d9cd20c34f345336e5 WHIRLPOOL fcc80ffe73bb3733733785587e84b0ab7de39a0916e5070c6cbdf499115e6da51a078f9d8176f4a15305c1b623cd59469385eaeeba33bbcb0116203f7c1704c7
DIST versioneer-0.16.tar.gz 37736 SHA256 67f9c595eba7479fc5afd867642e21b1a97d2e8cbff9684ad47d41a0db4b3048 SHA512 90604d69351c822dd5a1e8eaddbe6af2e77895c7e29148a75306833f04c59e18ae8ab6c928860ce3b8c7ac46245f2ed856485fdcffd790f436e689c408ddeca3 WHIRLPOOL 4bd1db6170736ba23e3ce36015f2c096aa17447d2fdebd738d4eca5996df705e17a5b791387a93a663aa8e3ceb120ab96150e9ec1d5f9f3a6650d1f3c21b22f0
30 changes: 30 additions & 0 deletions dev-python/versioneer/versioneer-0.16.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )

inherit distutils-r1

DESCRIPTION="Easy VCS-based management of project version strings"
HOMEPAGE="https://pypi.python.org/pypi/versioneer https://github.com/warner/python-versioneer"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

SLOT="0"
LICENSE="public-domain"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE=""

RDEPEND=""
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"

python_test() {
esetup.py make_versioneer
git config --global user.email "[email protected]"
git config --global user.name "Your Name"

${PYTHON} test/git/test_git.py -v || die
}

0 comments on commit c0c66fe

Please sign in to comment.