Skip to content

Commit

Permalink
games-action/violetland: Version bump to 0.5, EAPI 7
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.79, Repoman-2.3.17
Signed-off-by: James Le Cuirot <[email protected]>
  • Loading branch information
chewi committed Nov 10, 2019
1 parent 21b355e commit c0e24dd
Show file tree
Hide file tree
Showing 3 changed files with 62 additions and 1 deletion.
1 change: 1 addition & 0 deletions games-action/violetland/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST violetland-0.4.3.tar.gz 9257919 BLAKE2B 255c9c13a49db576a37dbd4aa863306f0778f9528173426b26934a674dd0145574ff96242577feff8a4566571eebd97d0cb7a1d8a9718ac84fcd6c4492230fd5 SHA512 678e1aea42c9358794c6b8b83bdd113baf26e16db4cb815c756cb6c1d268b8210d18a47d1a98a019556633b4db62cd8cf7fc6a1e1ec3b7e3647a9d8353020fae
DIST violetland-0.5-source-with-dependencies.tar.gz 11495885 BLAKE2B 33c3e8a8955ddc416c66c761681dce337ecccdb52ae7be3777124f4854c325436296ea5614100527a3e5be6c4d3a3cf2dffb2336037d5e904b50e2ae843d0fc4 SHA512 9b00fa600332c956c49bc5906f373c0dfff08a13320617014942ac4dbc199de8f84bef87ed218b38812ae3c53622e9148aa4463c4ea219056360bff1c73b7f88
2 changes: 1 addition & 1 deletion games-action/violetland/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -6,6 +6,6 @@
<name>Gentoo Games Project</name>
</maintainer>
<upstream>
<remote-id type="github">violetland</remote-id>
<remote-id type="github">ooxi/violetland</remote-id>
</upstream>
</pkgmetadata>
60 changes: 60 additions & 0 deletions games-action/violetland/violetland-0.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake-utils desktop xdg-utils

DESCRIPTION="Help a girl named Violet in the struggle with hordes of monsters"
HOMEPAGE="https://violetland.github.io/"
SRC_URI="https://github.com/ooxi/${PN}/releases/download/${PV}/${P}-source-with-dependencies.tar.gz"

LICENSE="GPL-3 CC-BY-SA-3.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="
dev-libs/boost:=[threads(+)]
media-libs/libsdl[sound,video]
media-libs/sdl-image[png]
media-libs/sdl-mixer[vorbis]
media-libs/sdl-ttf
virtual/opengl
"

DEPEND="${RDEPEND}"

BDEPEND="
sys-devel/gettext
"

src_prepare() {
cmake-utils_src_prepare

# Bizarrely fcitx is only bundled for a CMake module to find libintl
# but let's make sure the rest remains unused.
rm -r lib/fcitx/src || die
}

src_configure() {
local mycmakeargs=(
-DDATA_INSTALL_DIR="${EPREFIX}/usr/share/${PN}"
-DLOCALE_INSTALL_DIR=share/locale
)

cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install
dodoc CHANGELOG.md CONTRIBUTORS.md

# Remove duplicate READMEs.
rm -r "${ED}"/usr/share/${PN}/README* || die

newicon -s 64 icon-light.png ${PN}.png
make_desktop_entry ${PN} VioletLand
}

pkg_postinst() { xdg_icon_cache_update; }
pkg_postrm() { xdg_icon_cache_update; }

0 comments on commit c0e24dd

Please sign in to comment.