Skip to content

Commit

Permalink
media-gfx/sane-frontends: EAPI 6 bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
Amynka committed Aug 12, 2017
1 parent 0183043 commit c0fa8b1
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 2 deletions.
4 changes: 2 additions & 2 deletions media-gfx/sane-frontends/files/MissingCapsFlag.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- src/gtkglue.c 2005-04-16 15:12:07.000000000 +0200
+++ src/gtkglue.c.new 2009-06-24 00:26:46.000000000 +0200
--- a/src/gtkglue.c 2005-04-16 15:12:07.000000000 +0200
+++ b/src/gtkglue.c 2009-06-24 00:26:46.000000000 +0200
@@ -1476,8 +1476,7 @@
|| opt->type == SANE_TYPE_GROUP || !dialog->element[i].widget)
continue;
Expand Down
54 changes: 54 additions & 0 deletions media-gfx/sane-frontends/sane-frontends-1.0.14-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils

DESCRIPTION="Scanner Access Now Easy"
HOMEPAGE="http://www.sane-project.org"
SRC_URI="ftp://ftp.sane-project.org/pub/sane/${P}/${P}.tar.gz
ftp://ftp.sane-project.org/pub/sane/old-versions/${P}/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="gimp"

RDEPEND=""
DEPEND="media-gfx/sane-backends
gimp? ( media-gfx/gimp )"

PATCHES=( "${FILESDIR}/MissingCapsFlag.patch" )

src_configure () {
local myconf=""
use gimp || myconf="--disable-gimp"
use gimp && ! has_version ">=media-gfx/gimp-2" && myconf="--enable-gimp12"
econf \
--datadir=/usr/share/misc \
${myconf}
emake
}

src_install () {
local gimpplugindir
local gimptool
emake DESTDIR="${D}" install
if use gimp; then
for gimptool in gimptool gimptool-2.0 gimptool-1.2; do
if [ -x /usr/bin/${gimptool} ]; then
einfo "Setting plugin link for GIMP version $(/usr/bin/${gimptool} --version)"
gimpplugindir=$(/usr/bin/${gimptool} --gimpplugindir)/plug-ins
break
fi
done
if [ "/plug-ins" != "${gimpplugindir}" ]; then
dodir ${gimpplugindir}
dosym /usr/bin/xscanimage ${gimpplugindir}/xscanimage
else
ewarn "No idea where to find the gimp plugin directory"
fi
fi
dodoc AUTHORS Changelog NEWS PROBLEMS README
}

0 comments on commit c0fa8b1

Please sign in to comment.