Skip to content

Commit

Permalink
games-util/heroic-bin: bump to 2.12.0
Browse files Browse the repository at this point in the history
Signed-off-by: Maciej Barć <[email protected]>
  • Loading branch information
xgqt committed Jan 8, 2024
1 parent 38076ea commit c107ac8
Show file tree
Hide file tree
Showing 2 changed files with 135 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-util/heroic-bin/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST com.heroicgameslauncher.hgl.desktop-6dfb2758e531af693f0baffa15240f152aadd68b 317 BLAKE2B e4c7cc834bc8688703b982897b13542543a3d28c50f7fe3f8e680c233762d612c0b24f7036919571451b96002f493cb55fb6d75241e124879ae486c5b4053f96 SHA512 314c7449ee7b83c77eda117536d0c2da1c5d3882a3f08f5fe0381451de734ed388e8941de8440521dad2f2fc335d214345e7301a2929b8fefa4f64a7a2ff804e
DIST com.heroicgameslauncher.hgl.png-6dfb2758e531af693f0baffa15240f152aadd68b 9797 BLAKE2B c6f76df4ec2fd25323f5c37e03605647ede8f8c2ed48cfbb8af11aad22ae90182d3678b943633b46a2d8dfb0c1cbd1a275b6c62dde238b9b0f68cbafb4bf3697 SHA512 68e9881fb4f123008398409825aa8cf70cec34365a23adb1234f7c054a14f40d159e7d8912cfedac0bb2b12f1d3c3c980469c2fca9735d4bc06bd4074aecc7e3
DIST heroic-bin-2.11.0.tar.xz 103219320 BLAKE2B 9988ea1ae6ec4bd7d7b93d6d39cacf3b4bb954688109f2d111e90c77c64677182140f5d8d7075e756893bc17b546ec95d4813a9fe2b802542d9458ee0d06d490 SHA512 364a9300cb1e026470ffe69052ecb1fa9936811c3c84a89338929c51774eaf421e326463b359b6e069c4499a074f05458937a80b66837ede7387e3b9ccee35b3
DIST heroic-bin-2.12.0.tar.xz 105164628 BLAKE2B 6008967e943f843cb1d9b55db06c7a150bfdaf3f90b166bc2e133f044ac58e56b2c03efd4dfc1971b24d0303120a662ca655ae7b299ebdd890710d311724793c SHA512 c80c9130e07dedbe7573778acd39cf30f121076bd03705173d50617aedeb74154ead1c8959d7d9ba5cb51577488e078bf594e0068a2f251dc8b78002465bb369
134 changes: 134 additions & 0 deletions games-util/heroic-bin/heroic-bin-2.12.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,134 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

APP_NAME="${P/-bin/}"
APP_URI="https://github.com/Heroic-Games-Launcher/HeroicGamesLauncher"
APP_RESOURCES_COMMIT=6dfb2758e531af693f0baffa15240f152aadd68b

CHROMIUM_LANGS="
af am ar bg bn ca cs da de el en-GB en-US es es-419 et fa fi fil fr gu he hi
hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv
sw ta te th tr uk ur vi zh-CN zh-TW
"
PYTHON_COMPAT=( python3_{10..12} )

inherit chromium-2 desktop python-single-r1 xdg

DESCRIPTION="GOG and Epic Games Launcher for Linux"
HOMEPAGE="https://heroicgameslauncher.com/
https://github.com/Heroic-Games-Launcher/HeroicGamesLauncher/"
SRC_URI="
${APP_URI}/releases/download/v${PV}/heroic-${PV}.tar.xz
-> ${P}.tar.xz
${APP_URI}/raw/${APP_RESOURCES_COMMIT}/flatpak/com.heroicgameslauncher.hgl.desktop
-> com.heroicgameslauncher.hgl.desktop-${APP_RESOURCES_COMMIT}
${APP_URI}/raw/${APP_RESOURCES_COMMIT}/flatpak/com.heroicgameslauncher.hgl.png
-> com.heroicgameslauncher.hgl.png-${APP_RESOURCES_COMMIT}
"
S="${WORKDIR}/${APP_NAME}"

LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="
${PYTHON_DEPS}
app-accessibility/at-spi2-core
app-arch/brotli
app-arch/bzip2
dev-libs/expat
dev-libs/fribidi
dev-libs/glib
dev-libs/gmp
dev-libs/libffi
dev-libs/libpcre2
dev-libs/libtasn1
dev-libs/nettle
dev-libs/nspr
dev-libs/nss
dev-libs/wayland
media-fonts/freefont
media-gfx/graphite2
media-libs/alsa-lib
media-libs/fontconfig
media-libs/freetype
media-libs/harfbuzz
media-libs/libepoxy
media-libs/libjpeg-turbo
media-libs/libpng
media-libs/mesa
media-video/ffmpeg
net-dns/libidn2
net-libs/gnutls
net-print/cups
sys-apps/dbus
sys-libs/glibc
sys-libs/zlib
x11-libs/cairo
x11-libs/gdk-pixbuf
x11-libs/gtk+:3
x11-libs/libX11
x11-libs/libXau
x11-libs/libXcomposite
x11-libs/libXcursor
x11-libs/libXdamage
x11-libs/libXdmcp
x11-libs/libXext
x11-libs/libXfixes
x11-libs/libXi
x11-libs/libXrandr
x11-libs/libXrender
x11-libs/libdrm
x11-libs/libxcb
x11-libs/libxkbcommon
x11-libs/pango
x11-libs/pixman
"

QA_PREBUILT=".*"

src_unpack() {
unpack "${P}.tar.xz"
}

src_configure() {
default

chromium_suid_sandbox_check_kernel_config
}

src_prepare() {
default

cd locales || die
chromium_remove_language_paks
}

src_install() {
local app_root=/opt/${APP_NAME}
local app_dest="${ED}"/${app_root}

dodoc LICENSE.*
rm LICENSE.* || die

dodir "${app_root%/*}"
cp -r "${S}" "${app_dest}" || die

dosym -r "${PYTHON}" \
"${app_root}"/resources/app.asar.unpacked/node_modules/register-scheme/build/node_gyp_bins/python3

find "${app_dest}" -type f -name "*.a" -exec rm {} + || die

dosym -r "${app_root}"/heroic /usr/bin/heroic-run

# Install resources: desktop file and icon.
newmenu "${DISTDIR}"/com.heroicgameslauncher.hgl.desktop-${APP_RESOURCES_COMMIT} \
com.heroicgameslauncher.hgl.desktop
newicon "${DISTDIR}"/com.heroicgameslauncher.hgl.png-${APP_RESOURCES_COMMIT} \
com.heroicgameslauncher.hgl.png
}

0 comments on commit c107ac8

Please sign in to comment.