Skip to content

Commit

Permalink
dev-python/botocore: Bump to 1.29.42
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Jan 4, 2023
1 parent d63f5f5 commit c1465fd
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/botocore/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST botocore-1.29.32.gh.tar.gz 11048130 BLAKE2B 42c1fd07f0501c5815c05ff8ad2d63d1e90e22835e1df274a7a7dbd77d0edd111c6bd596e2c4489a54982629ad5c525cc558db71f5f06d07cc6a80084f3cb274 SHA512 4ae8f60ee36999848944ebb122fbc3bfde0730d5e2450fa25d7f608e277534bce49fef93e2e21db315edfbda795a130b7ce63644f5a3627cbed4b7905bbb1f99
DIST botocore-1.29.37.gh.tar.gz 11077206 BLAKE2B 59c877edba074d4d5858dbf0a4026c0884cc4fce5bc2c9a7d933cfbff8317825663955205ebc754f8a4713b817b7d775fe208d6946f788a1943989949da58a04 SHA512 e79447fe66a506326c5f6396a32b5f4f6560038c57ab03457c36c838f52c1e48a94cba7624350a738eb937d0f3954984b77fd97ffb4becfa72cc4c61005efd40
DIST botocore-1.29.41.gh.tar.gz 11082628 BLAKE2B a42a66299715159e82bb7bd9ceb5d1d60e88bfe2f59f66231605c909b03110ec18e6f946690c5b33e662fc92719e45fa4cf64ac31176d809908f3574fece5d49 SHA512 b3a5409f3d868c93fd038687d8c864be3c9cacbf4740ba0dd745358cadcce9aa8d76616d7f93316ac14f5f94f18ed42505ec108e2557b234b26c01ca0f3fc22c
DIST botocore-1.29.42.gh.tar.gz 11083372 BLAKE2B 8abca30fbd4bb55d8a0beccc6e81d3da60086230cf55a7ed384491e4bccaf2c5791fccc700ccc737b04b09bdfca4fa4feb3cddb7d0a72c37dccd71d4f6979901 SHA512 56c8859012dcdbf73c2417fc6feb32bf212e07fba5702a51bfb9bbcd446a3a34493a5a9e50369fb223f06c2afa9541eb584252391b09d667a9d13bfda32dfac5
74 changes: 74 additions & 0 deletions dev-python/botocore/botocore-1.29.42.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..11} )

inherit distutils-r1 multiprocessing

DESCRIPTION="Low-level, data-driven core of boto 3"
HOMEPAGE="
https://github.com/boto/botocore/
https://pypi.org/project/botocore/
"
LICENSE="Apache-2.0"
SLOT="0"

if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://github.com/boto/botocore"
inherit git-r3
else
SRC_URI="
https://github.com/boto/botocore/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
fi

RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
<dev-python/jmespath-2[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
>=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/jsonschema[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
"

distutils_enable_sphinx docs/source \
'dev-python/guzzle_sphinx_theme'
distutils_enable_tests pytest

src_prepare() {
# unpin deps
sed -i -e "s:>=.*':':" setup.py || die

# unbundle deps
rm -r botocore/vendored || die
find -name '*.py' -exec sed -i \
-e 's:from botocore[.]vendored import:import:' \
-e 's:from botocore[.]vendored[.]:from :' \
{} + || die

distutils-r1_src_prepare
}

python_test() {
local EPYTEST_DESELECT=(
# rely on bundled six
tests/functional/test_six_imports.py::test_no_bare_six_imports
tests/functional/test_six_threading.py::test_six_thread_safety
# fails on unrelated warnings
tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
# TODO
tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
)

epytest tests/{functional,unit} -n "$(makeopts_jobs)"
}

0 comments on commit c1465fd

Please sign in to comment.