forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-portage/eclass-manpages: Use portageq to detect overlay locations
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <[email protected]>
- Loading branch information
Showing
1 changed file
with
40 additions
and
0 deletions.
There are no files selected for viewing
40 changes: 40 additions & 0 deletions
40
app-portage/eclass-manpages/eclass-manpages-20150814-r1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,40 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
|
||
DESCRIPTION="collection of Gentoo eclass manpages" | ||
HOMEPAGE="https://www.gentoo.org/" | ||
SRC_URI="" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris" | ||
IUSE="" | ||
|
||
S=${WORKDIR} | ||
|
||
genit() { | ||
local e=${1:-${ECLASSDIR}} | ||
einfo "Generating man pages from: ${e}" | ||
# Need `bash` because the .sh isn't +x on the servers #451352 | ||
env ECLASSDIR=${e} bash "${FILESDIR}"/eclass-to-manpage.sh || die | ||
} | ||
|
||
src_compile() { | ||
# First process any eclasses found in overlays. Then process | ||
# the main eclassdir last so that its output will clobber anything | ||
# that might have come from overlays. Main tree wins! | ||
local o e | ||
for o in $(portageq get_repos /) ; do | ||
e="$(portageq get_repo_path / ${o})/eclass" | ||
[[ -d ${e} ]] || continue | ||
genit "${e}" || die | ||
done | ||
genit || die | ||
} | ||
|
||
src_install() { | ||
doman *.5 | ||
} |