forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <[email protected]>
- Loading branch information
Jeroen Roovers
committed
Jan 6, 2020
1 parent
223e11e
commit c163f77
Showing
2 changed files
with
50 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST remind-03.01.15.tar.gz 363101 BLAKE2B a5e27b83c20428991982c3cae22b32be6cc054bfd51a868ee3515f5ec4a37aa24f8ec476f566860ca0fbb6f29e7c9f3e6ed023714e52091ebca103162936877f SHA512 335f3ca88237f1ae53768b9ecdeb03f0bb1e706a8afd3ba36121ec76048a08fbc0d5ec72b05e552394b4cf2131be335c49533e1212b7e713ef16002a0621fc84 | ||
DIST remind-03.01.16.tar.gz 354521 BLAKE2B b4157922842af67408423e1b36ddae8f049e9c803cec83a7a11188dff5ccf7934ce5afc776bdc02acd6b18a8ad172180841a53576220791fb64230a0e1d54884 SHA512 61d72b01315d59a0e6f96006d5cb063752efad68119e2d1c4fcf6e6f3b2c122a7df47081c305f777fb2c6574e278e401446192897e48b4f93607db29db046550 | ||
DIST remind-03.01.17.tar.gz 355331 BLAKE2B c3c45b58763a02c951ff5b890ba7ee657894f54ac8b235c7c0f5bb83385b7ae867d660dc37ed71f5f35bd17a5668a8ac3a99bc76c22c000642419ddf90b3fd5b SHA512 e5d98c9e2b90a9d31f1298f252c12ff6be378e7d1501e4a8d3361eb349bf50e89aa1bc6b6543f052f3ffa4113241816117a83eb144b8cf452cf0af8b9d0c8a17 | ||
DIST remind-03.02.00.tar.gz 365896 BLAKE2B 3ee47e5c0093c56a2ed95d41eff815ebac26523b64dc09b91ee46d66bac6b2b017d73902ffac61dd12c2088dac8d445fb41d832e22692f47e6e125162f0d436e SHA512 978ee2e6a45756e02bc2de0495d95c4b4377d9af76cb1ea5070f8e2438a451d2bf44245b93018bcbf6ea217520b7b4c8766d5eab354f9a0bc4982b25e90bd278 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,49 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
DESCRIPTION="Ridiculously functional reminder program" | ||
HOMEPAGE="https://dianne.skoll.ca/projects/remind/" | ||
SRC_URI="https://dianne.skoll.ca/projects/remind/download/${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~x86" | ||
IUSE="tk" | ||
|
||
RDEPEND=" | ||
tk? ( dev-lang/tk dev-tcltk/tcllib ) | ||
" | ||
DOCS="docs/WHATSNEW examples/defs.rem www/README.*" | ||
|
||
src_prepare() { | ||
default | ||
sed -i 's:$(MAKE) install:&-nostripped:' "${S}"/Makefile || die | ||
} | ||
|
||
src_test() { | ||
if [[ ${EUID} -eq 0 ]] ; then | ||
ewarn "Testing fails if run as root. Skipping tests" | ||
else | ||
emake test | ||
fi | ||
} | ||
|
||
src_install() { | ||
default | ||
dobin www/rem2html | ||
|
||
if ! use tk ; then | ||
rm \ | ||
"${D}"/usr/bin/cm2rem* \ | ||
"${D}"/usr/bin/tkremind \ | ||
"${D}"/usr/share/man/man1/cm2rem* \ | ||
"${D}"/usr/share/man/man1/tkremind* \ | ||
|| die | ||
fi | ||
|
||
rm "${S}"/contrib/rem2ics-*/{Makefile,rem2ics.spec} || die | ||
insinto /usr/share/${PN} | ||
doins -r contrib/ | ||
} |