Skip to content

Commit

Permalink
dev-python/sqlalchemy-migrate: drop dep on sphinxcontrib-issuetracker
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/527188
Signed-off-by: Virgil Dupras <[email protected]>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
  • Loading branch information
Virgil Dupras committed Oct 10, 2018
1 parent 9194c71 commit c17b31c
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
intersphinx: prevent resource downloads at build time\
issuetracker: broken. see bug #527188
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -28,7 +28,7 @@ sys.path.append(os.path.dirname(os.path.abspath('.')))

# Add any Sphinx extension module names here, as strings. They can be extensions
# coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
-extensions = ['sphinx.ext.autodoc', 'sphinx.ext.intersphinx', 'sphinxcontrib.issuetracker']
+extensions = ['sphinx.ext.autodoc']

# link to sqlalchemy docs
intersphinx_mapping = {
43 changes: 43 additions & 0 deletions dev-python/sqlalchemy-migrate/sqlalchemy-migrate-0.11.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )

inherit distutils-r1

DESCRIPTION="SQLAlchemy Schema Migration Tools"
HOMEPAGE="https://pypi.org/project/sqlalchemy-migrate/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="doc"

CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
${CDEPEND}
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
RDEPEND=">=dev-python/sqlalchemy-0.7.8[${PYTHON_USEDEP}]
!~dev-python/sqlalchemy-0.9.5[${PYTHON_USEDEP}]
dev-python/decorator[${PYTHON_USEDEP}]
>=dev-python/six-1.7.0[${PYTHON_USEDEP}]
dev-python/python-sqlparse[${PYTHON_USEDEP}]
>=dev-python/tempita-0.4[${PYTHON_USEDEP}]"
# Testsuite requires a missing dep and errors with poor report output

PATCHES=( "${FILESDIR}/${PN}-0.11-disable-sphinx-exts.patch" )

python_compile_all() {
if use doc; then
einfo ""; einfo "The build seeks to import modules from an installed state of the package"
einfo "simply ignore all warnings / errors of failure to import module migrate.<module>"; einfo ""
emake -C doc/source html || die "Generation of documentation failed"
fi
}

python_install_all() {
use doc && local HTML_DOCS=( doc/source/_build/html/. )
distutils-r1_python_install_all
}

0 comments on commit c17b31c

Please sign in to comment.