Skip to content

Commit

Permalink
games-simulation/openttd: Bump to version 1.8.0_rc1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
Lars Wendler committed Mar 27, 2018
1 parent 7fdd6af commit c192403
Show file tree
Hide file tree
Showing 2 changed files with 176 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-simulation/openttd/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST openttd-1.7.1-source.tar.gz 10090311 BLAKE2B 339171cd2895398ee1fedcfd24d1126fbc060b6d4530b267310b3f220448f8e6469a726e71e9882bea117585ea7b9f7271205f576ee2b26de6dec079f57f1620 SHA512 4a0d2ee424374b50fe0d089b86ff16b5de3159848a38143ca6745e349b6126567f1e4beda9afe2e6bc21ffffce1166acf719d3f5c95703a14c1379f8857e83d3
DIST openttd-1.7.2-source.tar.gz 10097175 BLAKE2B a027b6ca6d3116dc3e6ad6ae43965682107268e367032418200cf1c1e16c5b5dad39c275ea57d923f17564d80cceb0e9909dc5aaf7ee230242f0ce0f46f06b1a SHA512 44d25061c42cb9c81baa67a40ff31a6681dcbb121c61db74c5179a31f189919471a82b7fd3f79c2cdeef02af5b47ec35fdbdc7feed74ca2360c028869fe772e8
DIST openttd-1.8.0-RC1-source.tar.xz 6520976 BLAKE2B 17d34378ba3aa7a9def9f3ff764c42b890a646946211184660c3af9e252b9a809d481ccdd31421442efd9c7fac86f5c9c6091987070d53d1c913d3ef680f413c SHA512 aff6833934ce875320bdba3410be15a53fc8c233e7efe60628158636eed3b179fea5c8e9f8af2181c16bc173c409eab93477f2165d448100d048959bf63ba3d2
175 changes: 175 additions & 0 deletions games-simulation/openttd/openttd-1.8.0_rc1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,175 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit eutils gnome2-utils

MY_PV="${PV/_rc/-RC}"
MY_P="${PN}-${MY_PV}"

DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
HOMEPAGE="http://www.openttd.org/"
SRC_URI="http://binaries.openttd.org/releases/${MY_PV}/${MY_P}-source.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE="aplaymidi debug dedicated iconv icu lzo +openmedia +png cpu_flags_x86_sse +timidity +truetype zlib"
RESTRICT="test" # needs a graphics set in order to test

RDEPEND="!dedicated? (
media-libs/libsdl[sound,X,video]
icu? (
dev-libs/icu-layoutex
dev-libs/icu-le-hb
>=dev-libs/icu-58.1:=
)
truetype? (
media-libs/fontconfig
media-libs/freetype:2
sys-libs/zlib
)
)
lzo? ( dev-libs/lzo:2 )
iconv? ( virtual/libiconv )
png? ( media-libs/libpng:0 )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
PDEPEND="
!dedicated? (
openmedia? (
games-misc/openmsx
games-misc/opensfx
)
aplaymidi? ( media-sound/alsa-utils )
!aplaymidi? ( timidity? ( media-sound/timidity++ ) )
)
openmedia? ( >=games-misc/opengfx-0.4.7 )"

S="${WORKDIR}/${MY_P}"

PATCHES=(
"${FILESDIR}"/${PN}-1.6.0-cflags.patch
)

src_configure() {
local myopts=()
# there is an allegro interface available as well as sdl, but
# the configure for it looks broken so the sdl interface is
# always built instead.
local myopts+=( --without-allegro )

# libtimidity not needed except for some embedded platform
# nevertheless, it will be automagically linked if it is
# installed. Hence, we disable it.
myopts+=( --without-libtimidity )

use debug && myopts+=( --enable-debug=3 )

if use dedicated ; then
myopts+=( --enable-dedicated )
else
use aplaymidi && myopts+=( --with-midi='/usr/bin/aplaymidi' )
myopts+=(
$(use_with truetype freetype)
$(use_with icu)
--with-sdl
)
fi
if use png || { use !dedicated && use truetype; } || use zlib ; then
myopts+=( --with-zlib )
else
myopts+=( --without-zlib )
fi

# configure is a hand-written bash-script, so econf will not work.
# It's all built as C++, upstream uses CFLAGS internally.
CFLAGS="" ./configure \
--disable-strip \
--prefix-dir="${EPREFIX%/}/usr" \
--binary-dir="bin" \
--install-dir="${D}" \
--menu-group="Game;Simulation;" \
${myopts[@]} \
$(use_with iconv) \
$(use_with png) \
$(use_with cpu_flags_x86_sse sse) \
$(use_with lzo liblzo2) \
|| die
}

src_compile() {
emake VERBOSE=1
}

src_install() {
default
if use dedicated ; then
newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
rm -rf "${ED}"/usr/share/{applications,icons,pixmaps}
fi
rm -f "${ED}"/usr/share/doc/${PF}/COPYING
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postinst() {
gnome2_icon_cache_update

if ! use lzo ; then
elog "OpenTTD was built without 'lzo' in USE. While 'lzo' is not"
elog "required, disabling it does mean that loading old savegames"
elog "or scenarios from ancient versions (~0.2) will fail."
elog
fi

if use dedicated ; then
ewarn "Warning: The init script will kill all running openttd"
ewarn "processes when triggered, including any running client sessions!"
else
if use aplaymidi ; then
elog "You have emerged with 'aplaymidi' for playing MIDI."
elog "This option is for those with a hardware midi device,"
elog "or who have set up ALSA to handle midi ports."
elog "You must set the environment variable ALSA_OUTPUT_PORTS."
elog "Available ports can be listed by using 'aplaymidi -l'."
else
if ! use timidity ; then
elog "OpenTTD was built with neither 'aplaymidi' nor 'timidity'"
elog "in USE. Music may or may not work in-game. If you happen"
elog "to have timidity++ installed, music will work so long"
elog "as it remains installed, but OpenTTD will not depend on it."
fi
fi
if ! use openmedia ; then
elog
elog "OpenTTD was compiled without the 'openmedia' USE flag."
elog
elog "In order to play, you must at least install:"
elog "games-misc/opengfx, and games-misc/opensfx, or copy the "
elog "following 6 files from a version of Transport Tycoon Deluxe"
elog "(windows or DOS) to ~/.openttd/data/ or"
elog "${GAMES_DATADIR}/${PN}/data/."
elog
elog "From the WINDOWS version you need: "
elog "sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
elog "OR from the DOS version you need: "
elog "SAMPLE.CAT TRG1.GRF TRGC.GRF TRGH.GRF TRGI.GRF TRGT.GRF"
elog
elog "File names are case sensitive, but should work either with"
elog "all upper or all lower case names"
elog
elog "In addition, in-game music will be unavailable: for music,"
elog "install games-misc/openmsx, or use the in-game download"
elog "functionality to get a music set"
elog
fi
fi
}

pkg_postrm() {
gnome2_icon_cache_update
}

0 comments on commit c192403

Please sign in to comment.