Skip to content

Commit

Permalink
app-arch/rar: bump to v6.10
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Jan 26, 2022
1 parent 5cac77b commit c1a3e56
Show file tree
Hide file tree
Showing 2 changed files with 112 additions and 0 deletions.
3 changes: 3 additions & 0 deletions app-arch/rar/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,6 @@
DIST rarlinux-6.0.2_p20210611.tar.gz 610546 BLAKE2B 927a7f60af431e84e9ff19dc1abf52c4697068264d3c67a17ada324bfb00975824e26937a19dea023cda772066991de719ec68fb1fb380f6656130af67202131 SHA512 6b6ef629dd0e681702fb0835cf6fe9962dc2ce774291f800893308a93a0a498099775e7d897d69375f68107b0ce0862bb2a6a169b8fbda534091678e9be3f09c
DIST rarlinux-x32-6.10_p20220124.tar.gz 616277 BLAKE2B 051a8c5689dd0924bc841fab05acd01cfaa7752a5ce54de71b727acedc6606d62605f3487af99d59af081acfbc1ded95ee427904caa6fee39734243248e73c13 SHA512 3593756eba8fd8e512ff1f0378e2768a264671dd25c139f00dc632b53d379ee6da4d63d6d94394f39ad4fde0310211d11d8c2d3167da5d576f16b299da969118
DIST rarlinux-x64-6.0.2_p20210611.tar.gz 599150 BLAKE2B ff60f32ee5215403e622bc5c341b8212c3deee0020155043e4c7c3d5feff113da351412a91fd42f46e3293dc5975fd2beca558e3e45744cdc5356ace82af6c93 SHA512 909eb3b05c56327ccec101652d1d68ca5eb97ba3a7223954724fbccf4960b07ffa0ff5fe5405c53a248342a3ae171325e7bbf7fadeaf63c1c45bf00853e0a940
DIST rarlinux-x64-6.10_p20220124.tar.gz 604344 BLAKE2B ab5a5b0c1e8aed44e6b55820e0d843adf526c0d48ab5128fff5e907fcc4969cd6645cef2a91abbe49b770de3104d9a8d09da34e0f9955fa9825da204ca1098c9 SHA512 56ea0f3eaf84ff41af6543056e71d9768285ceef00132fe9ea0c7ecb02e0681023b0f7940b02fe3918bf28de229d000e0209f66dd4af2e93c6d81c3bcbedc87b
DIST winrar-x64-6.0.2_p20210611.exe 3348968 BLAKE2B 482e5c34cae9c452b539f6e9e89efc7db8e463cc58b4db43cd25caa7e3fc6ab7945a7a17e9605b9d6d505c31a9a343a29812531dc5ba319765bf80fcc775426e SHA512 4c2bd804465e6bd948de248a7a0893f4b38728665b8e67c65bfc14766475072960250057ad1afc457a0df1f128da96d69483b000a5da18826776ea0a4377230a
DIST winrar-x64-6.10_p20220124.exe 3470848 BLAKE2B d54dc216dfcc251d9c3a06ebf49b0717954cab856231b9777597dc0d1b61b64bc5c5fbebe9546be42c44ba23a2d9dd8eaf3f5d5484678eda5d1ec3a8ebb159c1 SHA512 9968fe6b3c5df9f11690263246366da9544a5a05f535f61d9cbb6765fb81f2614a75b8b1b8c367d7b83c83a87b53b1b94f3ffaa95c38dbf368a880c16f136e63
109 changes: 109 additions & 0 deletions app-arch/rar/rar-6.10_p20220124.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,109 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

DESCRIPTION="RAR compressor/uncompressor"
HOMEPAGE="https://rarlab.com/"
URI_x86="https://mirror.whissi.de/distfiles/rar/rarlinux-x32-${PV}.tar.gz"
URI_amd64="https://mirror.whissi.de/distfiles/rar/rarlinux-x64-${PV}.tar.gz"
URI_w64="https://mirror.whissi.de/distfiles/rar/winrar-x64-${PV}.exe"
SRC_URI="x86? ( ${URI_x86} )
amd64? ( ${URI_amd64} )
all_sfx? (
${URI_x86}
${URI_amd64}
${URI_w64}
)"

LICENSE="RAR BSD BSD-2"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE="all_sfx"
RESTRICT="mirror bindist"

DEPEND="all_sfx? ( app-arch/unrar )"
RDEPEND="sys-libs/glibc"

S="${WORKDIR}/${PN}"

QA_FLAGS_IGNORED="opt/rar/default.sfx
opt/rar/default-elf32.sfx
opt/rar/default-elf64.sfx
opt/rar/default-win32.sfx
opt/rar/default-win64.sfx
opt/rar/WinCon.SFX
opt/rar/WinCon64.SFX
opt/rar/Zip.SFX
opt/rar/Zip64.SFX
opt/rar/unrar
opt/rar/rar"
QA_PRESTRIPPED=${QA_FLAGS_IGNORED}

src_unpack() {
local _file

for _file in ${A}; do
if [[ "${_file}" == rarli* ]]; then
if [[ "${_file}" =~ x64 ]]; then
if ! use amd64; then
continue
fi

unpack "${_file}"
elif [[ ! "${_file}" =~ x64 ]]; then
if ! use x86; then
continue
fi

unpack "${_file}"
else
die "Unknown SRC file '${_file}'!"
fi
fi
done

rm -f "${S}"/license.txt

if use all_sfx ; then
mkdir sfx
cd sfx
for _file in ${A}; do
if [[ "${_file}" == rarli* ]]; then
unpack "${_file}"
if [[ "${_file}" =~ x64 ]]; then
mv rar/default.sfx default-elf64.sfx || die
else
mv rar/default.sfx default-elf32.sfx || die
fi
elif [[ "${_file}" == winrar* ]]; then
ln -s "${DISTDIR}"/${_file} w64.rar || die
unpack ./w64.rar
mv Default.SFX default-win32.sfx || die
mv Default64.SFX default-win64.sfx || die
else
die "Unknown SFX file '${_file}'!"
fi
done
fi
}

src_compile() { :; }

src_install() {
exeinto /opt/rar
doexe rar unrar

dodir /opt/bin
dosym ../rar/rar /opt/bin/rar
dosym ../rar/unrar /opt/bin/unrar

insinto /opt/rar
if use all_sfx ; then
doins "${WORKDIR}"/sfx/*.{sfx,SFX}
else
doins default.sfx
fi
doins rarfiles.lst
dodoc *.txt
}

0 comments on commit c1a3e56

Please sign in to comment.