Skip to content

Commit

Permalink
kde-apps/dolphin: Return to old placement of 'Create New' context menu
Browse files Browse the repository at this point in the history
See also: https://phabricator.kde.org/D27267

Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Feb 15, 2020
1 parent 141e442 commit c1ef5f3
Show file tree
Hide file tree
Showing 2 changed files with 165 additions and 0 deletions.
99 changes: 99 additions & 0 deletions kde-apps/dolphin/dolphin-19.12.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,99 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

ECM_HANDBOOK="forceoptional"
ECM_TEST="true"
PVCUT=$(ver_cut 1-3)
KFMIN=5.63.0
QTMIN=5.12.3
VIRTUALX_REQUIRED="test"
inherit ecm kde.org

DESCRIPTION="Plasma filemanager focusing on usability"
HOMEPAGE="https://kde.org/applications/system/org.kde.dolphin
https://userbase.kde.org/Dolphin"

LICENSE="GPL-2" # TODO: CHECK
SLOT="5"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
IUSE="activities semantic-desktop"

DEPEND="
>=kde-frameworks/kbookmarks-${KFMIN}:5
>=kde-frameworks/kcmutils-${KFMIN}:5
>=kde-frameworks/kcodecs-${KFMIN}:5
>=kde-frameworks/kcompletion-${KFMIN}:5
>=kde-frameworks/kconfig-${KFMIN}:5
>=kde-frameworks/kconfigwidgets-${KFMIN}:5
>=kde-frameworks/kcoreaddons-${KFMIN}:5
>=kde-frameworks/kcrash-${KFMIN}:5
>=kde-frameworks/kdbusaddons-${KFMIN}:5
>=kde-frameworks/ki18n-${KFMIN}:5
>=kde-frameworks/kiconthemes-${KFMIN}:5
>=kde-frameworks/kinit-${KFMIN}:5
>=kde-frameworks/kio-${KFMIN}:5
>=kde-frameworks/kitemviews-${KFMIN}:5
>=kde-frameworks/kjobwidgets-${KFMIN}:5
>=kde-frameworks/knewstuff-${KFMIN}:5
>=kde-frameworks/knotifications-${KFMIN}:5
>=kde-frameworks/kparts-${KFMIN}:5
>=kde-frameworks/kservice-${KFMIN}:5
>=kde-frameworks/ktextwidgets-${KFMIN}:5
>=kde-frameworks/kwidgetsaddons-${KFMIN}:5
>=kde-frameworks/kwindowsystem-${KFMIN}:5
>=kde-frameworks/kxmlgui-${KFMIN}:5
>=kde-frameworks/solid-${KFMIN}:5
>=dev-qt/qtconcurrent-${QTMIN}:5
>=dev-qt/qtdbus-${QTMIN}:5
>=dev-qt/qtgui-${QTMIN}:5
>=dev-qt/qtwidgets-${QTMIN}:5
>=dev-qt/qtxml-${QTMIN}:5
media-libs/phonon[qt5(+)]
activities? ( >=kde-frameworks/kactivities-${KFMIN}:5 )
semantic-desktop? (
>=kde-frameworks/baloo-${KFMIN}:5
>=kde-frameworks/kfilemetadata-${KFMIN}:5
>=kde-apps/baloo-widgets-${PVCUT}:5
)
"
RDEPEND="${DEPEND}
>=kde-apps/kio-extras-${PVCUT}:5
"

RESTRICT+=" test"

PATCHES=( "${FILESDIR}/${P}-create-new-consistency.patch" ) # from 20.04

src_configure() {
local mycmakeargs=(
$(cmake_use_find_package activities KF5Activities)
$(cmake_use_find_package semantic-desktop KF5Baloo)
$(cmake_use_find_package semantic-desktop KF5BalooWidgets)
$(cmake_use_find_package semantic-desktop KF5FileMetaData)
)

ecm_src_configure
}

pkg_postinst() {
ecm_pkg_postinst

if [[ -z "${REPLACING_VERSIONS}" ]]; then
has_version "kde-apps/ark:${SLOT}" || \
elog "For compress/extract and other actions install kde-apps/ark:${SLOT}"

has_version "kde-apps/kleopatra:${SLOT}" || \
elog "For crypto actions install kde-apps/kleopatra:${SLOT}"

has_version "kde-apps/ffmpegthumbs:${SLOT}" || \
elog "For video file thumbnails install kde-apps/ffmpegthumbs:${SLOT}"

has_version "kde-apps/thumbnailers:${SLOT}" || \
elog "For graphics file thumbnails install kde-apps/thumbnailers:${SLOT}"

has_version "kde-frameworks/purpose:${SLOT}" || \
elog "For 'Share' context menu actions install kde-frameworks/purpose:${SLOT}"
fi
}
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
From 4c923a531f77bc4c44b5c8687fe18dd6438eb9c5 Mon Sep 17 00:00:00 2001
From: Nate Graham <[email protected]>
Date: Sun, 9 Feb 2020 08:58:10 -0700
Subject: Restore former position of "Create New" menu item in viewport context
menu

Summary:
I've seem various complaints from users about the fact that the {nav Create New...} menu
item in the viewport context menu is now below {nav Open With} item. All the other
changes to menus seem to have been well-received but this one has garnered criticism.
Looking through D23757 and D11884, I can't actually see that this was intentional, so
it might even be a bug.

Either way, this patch restores the old position of the {nav Create New} menu items at
the top of the Viewport context menu.

BUG: 417640
FIXED-IN: 20.04.0

Test Plan: {F8093605}

Reviewers: #vdg, #dolphin, elvisangelaccio, ndavis

Reviewed By: #vdg, ndavis

Subscribers: asturmlechner, markuss, kfm-devel

Tags: #dolphin

Differential Revision: https://phabricator.kde.org/D27267
---
src/dolphincontextmenu.cpp | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/src/dolphincontextmenu.cpp b/src/dolphincontextmenu.cpp
index 79143d4..9f39671 100644
--- a/src/dolphincontextmenu.cpp
+++ b/src/dolphincontextmenu.cpp
@@ -342,12 +342,6 @@ void DolphinContextMenu::openViewportContextMenu()
fileItemActions.setParentWidget(m_mainWindow);
fileItemActions.setItemListProperties(baseUrlProperties);

- // Don't show "Open With" menu items if the current dir is empty, because there's
- // generally no app that can do anything interesting with an empty directory
- if (view->itemsCount() != 0) {
- addOpenWithActions(fileItemActions);
- }
-
// Set up and insert 'Create New' menu
KNewFileMenu* newFileMenu = m_mainWindow->newFileMenu();
newFileMenu->setViewShowsHiddenFiles(view->hiddenFilesShown());
@@ -355,6 +349,12 @@ void DolphinContextMenu::openViewportContextMenu()
newFileMenu->setPopupFiles(QList<QUrl>() << m_baseUrl);
addMenu(newFileMenu->menu());

+ // Don't show "Open With" menu items if the current dir is empty, because there's
+ // generally no app that can do anything interesting with an empty directory
+ if (view->itemsCount() != 0) {
+ addOpenWithActions(fileItemActions);
+ }
+
QAction* pasteAction = createPasteAction();
addAction(pasteAction);

--
cgit v1.1

0 comments on commit c1ef5f3

Please sign in to comment.