Skip to content

Commit

Permalink
app-cdr/dvdshrink: Port to EAPI 6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
SoapGentoo committed Dec 28, 2017
1 parent e7b2e3e commit c210c56
Show file tree
Hide file tree
Showing 2 changed files with 29 additions and 12 deletions.
19 changes: 7 additions & 12 deletions app-cdr/dvdshrink/dvdshrink-2.6.1_p10.ebuild
Original file line number Diff line number Diff line change
@@ -1,8 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=2
inherit eutils
EAPI=6

inherit desktop

DESCRIPTION="Scriptable DVD copy software"
HOMEPAGE="http://dvdshrink.sourceforge.net"
Expand All @@ -24,21 +25,15 @@ RDEPEND=">=media-video/transcode-1.0.2-r2[dvd]
DEPEND=""

S=${WORKDIR}/${PN}

src_prepare() {
sed -e 's:applications/::g' -i usr/bin/dvdsfunctions \
-i usr/bin/xdvdshrink.pl || die "sed failed."
}
PATCHES=( "${FILESDIR}"/${PN}-2.6.1_p10-fix-paths.patch )

src_install() {
dobin usr/bin/{batchrip.sh,dvds{functions,hrink}} || die "dobin failed."
dobin usr/bin/{batchrip.sh,dvds{functions,hrink}}

if use gtk; then
dobin usr/bin/xdvdshrink.pl || die "dobin failed."
fi
use gtk && dobin usr/bin/xdvdshrink.pl

insinto /usr/share
doins -r usr/share/applications/dvdshrink || die "doins failed."
doins -r usr/share/applications/dvdshrink

dodoc usr/share/doc/dvdshrink/{batchrip.txt,example.xml,README.txt}

Expand Down
22 changes: 22 additions & 0 deletions app-cdr/dvdshrink/files/dvdshrink-2.6.1_p10-fix-paths.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
--- a/usr/bin/dvdsfunctions
+++ b/usr/bin/dvdsfunctions
@@ -1933,7 +1933,7 @@
if ! ((`ps -C xdvdshrink.pl > /dev/null 2>&1`)); then GUI=1; fi
SAVEISO=0 # Save an ISO along with the burn(s)

- APPDIR=/usr/share/applications/dvdshrink
+ APPDIR=/usr/share/dvdshrink
}

# Build a minimal but usable XML file for 'dvdauthor'
--- a/usr/bin/xdvdshrink.pl
+++ b/usr/bin/xdvdshrink.pl
@@ -22,7 +22,7 @@

my $login = getlogin || getpwuid($<); # Userid of current user
my $homedir = "/home/" . $login; # Home dir of current user
-my $app_dir = "/usr/share/applications/dvdshrink";
+my $app_dir = "/usr/share/dvdshrink";
my $false = 0; # A 'false'
my $true = 1; # A 'true'
my $srunning = 0; # Is the bash script running

0 comments on commit c210c56

Please sign in to comment.