forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
- Loading branch information
Jeroen Roovers
committed
Apr 14, 2017
1 parent
c93ab06
commit c25bf4c
Showing
3 changed files
with
52 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST p0f-2.0.8.tgz 136877 SHA256 6c4d8745f04e59f2ba68d56fd1554551592f08a0497c9fc21b84498f47d1aee0 SHA512 ccfc512a79df7acfad007c6d67398c5c0745be165095adc9dc4ba62cf165c962f98d92e038b3be4eb23cd13e3a9231827c4bd8a0a3bf0cdf68a38286188cde4f WHIRLPOOL 4e813f799e6fdec2728a72a720a5538eff637d8089bacc485c922fce1b64a58018e1dcff51c79e5551fd01d7647e681db507574873ffc020c3c710ea7398ffdd | ||
DIST p0f-3.06b.tgz 92054 SHA256 d151931be2557ac45f9baa0a9384b8643979f4227c391ed395792874f2c6cde7 SHA512 2fe9ed6049c8680ec994b071761f8351ad2f771a0ef2a423b007878c4a3b900d3c6a1a638fe4d72e4c300ce383ad19a7b4a1bf72e65acfa0bd11453a43cd46cc WHIRLPOOL c281f072af04ba8ba4ebcab87c0ed381d91cbd38eb306a43fa2d9a47083d642f539096282d218604ad6bba1800cd34962432bf5697996c930a5e7a2c4e425dc0 | ||
DIST p0f-3.07b.tgz 92414 SHA256 5cfc9a4b32e0e789d6ae3240e22c531e7dfb7906d833a026e45a5504379f0ba2 SHA512 79dd0637015055a5bf1f017ea3ae9d5b916c4299df0b364450ffb4a9d736c95a27a2874ac537cfcaec5e588fd507891ee7012d6d41459c6dd68638efc1a708da WHIRLPOOL 68b11ebde6ab356bd1c82173c6c2c8b4a840e251e60931c16b1989781b12a14b4f6a592050c729c17afbab2965390d21c0e4a18bac6c915ffd93ab9d0fd51079 | ||
DIST p0f-3.09b.tgz 92896 SHA256 543b68638e739be5c3e818c3958c3b124ac0ccb8be62ba274b4241dbdec00e7f SHA512 2a688baa865f27c91c023a7c53e530649f56a681e6ca2533152ab07b42883857b20c378b636e87dda8d1d5dfac17e426d09ee032b363d0b7d98e57a9ff6164d0 WHIRLPOOL 139fd50748b4dc84ddc31f0a4c093adf7ea8c3bedf2d83415aff6497534147734fa74a0804917d27afd5690248d3e547027dfbec03e68af69aea0c8625004782 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -5,5 +5,4 @@ | |
<email>[email protected]</email> | ||
<name>Gentoo network monitoring and analysis project</name> | ||
</maintainer> | ||
<longdescription>p0f performs passive OS detection based on SYN packets.</longdescription> | ||
</pkgmetadata> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,51 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit toolchain-funcs | ||
|
||
MY_P=${P/_beta/b} | ||
|
||
DESCRIPTION="A tool to perform passive OS detection based on SYN packets" | ||
HOMEPAGE="http://lcamtuf.coredump.cx/p0f3/" | ||
SRC_URI="http://lcamtuf.coredump.cx/p0f3/releases/${MY_P}.tgz" | ||
|
||
LICENSE="LGPL-2.1" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos" | ||
IUSE="debug ipv6" | ||
|
||
RDEPEND="net-libs/libpcap" | ||
DEPEND="${RDEPEND}" | ||
|
||
S=${WORKDIR}/${MY_P} | ||
|
||
src_prepare() { | ||
default | ||
|
||
sed -i \ | ||
-e 's:-g -ggdb::' \ | ||
-e 's:-O3::' \ | ||
-e '/^CC/s:=:?=:' \ | ||
-e '/^CFLAGS/s:=:+=:' \ | ||
-e '/^LDFLAGS/s:=:+=:' \ | ||
build.sh tools/Makefile || die | ||
|
||
sed -i -e "/FP_FILE/s:p0f.fp:${EPREFIX}/etc/&:" config.h || die | ||
} | ||
|
||
src_compile() { | ||
tc-export CC | ||
./build.sh $(use debug && echo debug) || die | ||
emake -C tools p0f-client p0f-sendsyn $(use ipv6 && echo p0f-sendsyn6) | ||
} | ||
|
||
src_install() { | ||
dosbin p0f tools/p0f-{client,sendsyn} | ||
use ipv6 && dosbin tools/p0f-sendsyn6 | ||
|
||
insinto /etc | ||
doins p0f.fp | ||
|
||
dodoc docs/{ChangeLog,README,TODO,*.txt} tools/README-TOOLS | ||
} |