Skip to content

Commit

Permalink
app-misc/mouseremote: use #!/sbin/openrc-run instead of #!/sbin/runsc…
Browse files Browse the repository at this point in the history
…ript

Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=573846

Package-Manager: portage-2.2.26
  • Loading branch information
austin987 committed Apr 26, 2016
1 parent d48eeb2 commit c25de1e
Show file tree
Hide file tree
Showing 2 changed files with 71 additions and 2 deletions.
4 changes: 2 additions & 2 deletions app-misc/mouseremote/files/mouseremote.start
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
#!/sbin/openrc-run
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down
69 changes: 69 additions & 0 deletions app-misc/mouseremote/mouseremote-0.90-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,69 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

inherit eutils

S="${WORKDIR}/MouseRemote"
DESCRIPTION="X10 MouseRemote"
HOMEPAGE="http://www4.pair.com/gribnif/ha/"
SRC_URI="http://www4.pair.com/gribnif/ha/MouseRemote.tar.gz"

SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 ~ppc x86"
IUSE=""

DEPEND="virtual/perl-Time-HiRes"

src_unpack() {
unpack ${A}
cd "${S}"

epatch "${FILESDIR}"/${P}-makefile.diff
epatch "${FILESDIR}"/${PN}-gentoo-${PVR}.diff
}

src_compile() {
cd MultiMouse && emake \
CC=$(tc-getCC) \
PREFIX=/usr \
LOCKDIR=/var/lock \
JMANDIR=/usr/share/man/ja_JP.ujis || die
}

src_install() {
dobin MultiMouse/multimouse || die
dosbin MultiMouse/multimoused || die

dodoc README MultiMouse/README.jis MultiMouse/README.newstuff || die
newdoc MultiMouse/README README.MultiMouse || die
newdoc client/MouseRemote.conf MouseRemote.conf.dist || die
newdoc client/MouseRemote.pl MouseRemote.pl.dist || die
newdoc client/MouseRemoteKeys.pl MouseRemoteKeys.pl.dist || die

newinitd "${FILESDIR}"/mouseremote.start mouseremote || die
newconfd "${FILESDIR}"/mouseremote.conf mouseremote || die
}

pkg_postinst() {
[ -e /dev/mumse ] || mkfifo "${ROOT}"/dev/mumse
[ -e /dev/x10fifo ] || mkfifo "${ROOT}"/dev/x10fifo

elog "To use the mouse function in X, add the following to your XF86Config"
elog "Section \"InputDevice\""
elog " Identifier \"MouseREM\""
elog " Driver \"mouse\""
elog " Option \"Protocol\" \"MouseSystems\""
elog " Option \"Device\" \"/dev/mumse\""
elog "EndSection"
elog
elog "Don't forget to add the new device to the section \"ServerLayout\""
elog "like: InputDevice \"MouseREM\" \"SendCoreEvents\""
elog
elog "Enable the daemon with \"rc-update add mouseremote default\"."
elog
elog "Configure the daemon is run in /etc/conf.d/mouseremote."
elog
elog "See /usr/share/doc/${PF} on how to configure the buttons."
}

0 comments on commit c25de1e

Please sign in to comment.