Skip to content

Commit

Permalink
dev-perl/Apache-CGI-Builder: Kill apache1 support, add tests
Browse files Browse the repository at this point in the history
- EAPI6
- Enable/extend tests (slightly)
- Kill all mentions of apache1
- Add missing mod_perl dep

Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
kentfredric committed Oct 13, 2017
1 parent 352b299 commit c286b97
Show file tree
Hide file tree
Showing 3 changed files with 113 additions and 1 deletion.
48 changes: 48 additions & 0 deletions dev-perl/Apache-CGI-Builder/Apache-CGI-Builder-1.300.0-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DIST_AUTHOR=DOMIZIO
DIST_VERSION=1.3
inherit perl-module

DESCRIPTION="CGI::Builder and Apache2/mod_perl2 integration"

SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND=">=dev-perl/OOTools-2.21
>=dev-perl/CGI-Builder-1.2
www-apache/mod_perl
"
RDEPEND="${DEPEND}"

PATCHES=( "${FILESDIR}/${P}-no-apache-1.patch" )

src_prepare() {
rm "${S}/lib/Apache/CGI/Builder.pm" || die "Can't remove Apache-1 support"
perl-module_src_prepare
}
src_test() {
local MODULES=(
"Apache2::CGI::Builder ${DIST_VERSION}"
)
local failed=()
for dep in "${MODULES[@]}"; do
ebegin "Compile testing ${dep}"
perl -Mblib="${S}" -M"${dep} ()" -e1
eend $? || failed+=( "$dep" )
done
if [[ ${failed[@]} ]]; then
echo
eerror "One or more modules failed compile:";
for dep in "${failed[@]}"; do
eerror " ${dep}"
done
die "Failing due to module compilation errors";
fi
perl_rm_files t/test_pod_coverage.t t/test_pod.t
perl-module_src_test
}
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
From ef931c54efda99718b71f9e772fb7474e6ae8953 Mon Sep 17 00:00:00 2001
From: Kent Fredric <[email protected]>
Date: Fri, 13 Oct 2017 18:19:42 +1300
Subject: Kill Apache1/mod_perl-1

---
MANIFEST | 1 -
Makefile.PL | 6 +-
lib/Apache/CGI/Builder.pm | 383 ----------------------------------------------
t/01_class.t | 2 +-
4 files changed, 4 insertions(+), 388 deletions(-)
delete mode 100644 lib/Apache/CGI/Builder.pm

diff --git a/MANIFEST b/MANIFEST
index 3dcf4d5..e5e1a8d 100644
--- a/MANIFEST
+++ b/MANIFEST
@@ -1,5 +1,4 @@
Changes
-lib/Apache/CGI/Builder.pm
lib/Apache2/CGI/Builder.pm
Makefile.PL
MANIFEST This list of files
diff --git a/Makefile.PL b/Makefile.PL
index 47272f9..babf555 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -3,10 +3,10 @@

; use ExtUtils::MakeMaker

-; my $pm = 'lib/Apache/CGI/Builder.pm'
+; my $pm = 'lib/Apache2/CGI/Builder.pm'

; WriteMakefile
- ( NAME => 'Apache::CGI::Builder'
+ ( NAME => 'Apache2::CGI::Builder'
, VERSION_FROM => $pm
, ( $] ge '5.005' )
? ( AUTHOR => 'Domizio Demichelis - perl.4pro.net'
@@ -16,7 +16,7 @@
, PREREQ_PM => { 'CGI::Builder' => 1.2
, 'Class::props' => 1.62
, 'Object::props' => 1.62
- , 'mod_perl' => 0
+ , 'mod_perl2' => 0
}
)

diff --git a/t/01_class.t b/t/01_class.t
index fce93e9..056453d 100644
--- a/t/01_class.t
+++ b/t/01_class.t
@@ -3,7 +3,7 @@
; use strict
; use Test::More tests => 1

-; use Apache::CGI::Builder
+; use Apache2::CGI::Builder

; ok(1)

--
2.14.2

1 change: 0 additions & 1 deletion dev-perl/Apache-CGI-Builder/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -8,6 +8,5 @@
<upstream>
<remote-id type="cpan">Apache-CGI-Builder</remote-id>
<remote-id type="cpan-module">Apache2::CGI::Builder</remote-id>
<remote-id type="cpan-module">Apache::CGI::Builder</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit c286b97

Please sign in to comment.