Skip to content

Commit

Permalink
app-emulation/faudio: add 24.06
Browse files Browse the repository at this point in the history
Signed-off-by: Michael Mair-Keimberger <[email protected]>
Closes: gentoo#37092
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
mm1ke authored and ConiKost committed Jun 22, 2024
1 parent 03301f9 commit c29dc56
Show file tree
Hide file tree
Showing 2 changed files with 38 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/faudio/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST faudio-23.02.tar.gz 1111012 BLAKE2B c776a5b882697fbbed894f129165600b1aad8b303254e9ecbf6111fff71581491b484681a71d377854077dfc23b99d1217e5322bdd9923caf4471cc0bc2ca0f2 SHA512 d83adca1f1e42b1c7d63dad30886b58a914ac9a5a254f26d3fdb2386776840e3c40b22a8dd9c7172e6c97b0db989f919fd2ebeac2ec00075a8136ec9120bc390
DIST faudio-23.10.tar.gz 1120033 BLAKE2B 2f064ba71386db69870b4e523625c421b2062f3584f834b55367dd675a1a61509831b036ed2e459cd2ea247e2b56401142bf73b6e828bd2ff4699623ba0d453f SHA512 cc17c1c3950267a8cc69d0a263deef1d80e8bb9f658f1c2cd1c137bccac1d2be234d17f9b790bbe8bd1ba9da7e13676d3d38e328399d5a706f6ed502365de9ba
DIST faudio-24.02.tar.gz 1122131 BLAKE2B 5ace47c679e7c35fc13157c1bdf6d8a8080fd9e3516f9007628875a2c67d1d2aab63404261c28aadcb33305c196c6e96ba8045d50e42d7f79d47ee0696bdb068 SHA512 de48196bc9d93784d2f2ce20c7aba83066a8a7653781104eb3b15fa8206e54875d5c555dab4c6fb763cf41fd6ec733e71b6bba53c8cafd98af99ea9eb0a3d666
DIST faudio-24.06.tar.gz 1125079 BLAKE2B 2664181d1fbed594b3f7af93877cb9f3ae1a9c34ed2e69d6307997e8b360045698d460912a1b689e060d9742fd002ce0370a6133dd944fa0b6e296949e679103 SHA512 d8fb3c2303c81163a26f437edce5ae428f4769a28107eb21f1fdb637421480928fc6f0031fc053caa762db901d659336a6e2ffad78ece9ab03ba4f312b00deb6
37 changes: 37 additions & 0 deletions app-emulation/faudio/faudio-24.06.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake flag-o-matic

DESCRIPTION="Accuracy-focused XAudio reimplementation for open platforms"
HOMEPAGE="https://fna-xna.github.io/"
SRC_URI="https://github.com/FNA-XNA/FAudio/archive/${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/FAudio-${PV}"

LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug dumpvoices test"
RESTRICT="!test? ( test )"

RDEPEND="media-libs/libsdl2[sound]"
DEPEND="${RDEPEND}"

src_configure() {
append-cppflags -D_DEFAULT_SOURCE # usleep() in tests
use debug || append-cppflags -DFAUDIO_DISABLE_DEBUGCONFIGURATION

local mycmakeargs=(
-DBUILD_TESTS=$(usex test)
-DDUMP_VOICES=$(usex dumpvoices)
)

cmake_src_configure
}

src_test() {
einfo "Running faudio_tests, this may take some time without output..."
SDL_AUDIODRIVER=dummy "${BUILD_DIR}"/faudio_tests || die
}

0 comments on commit c29dc56

Please sign in to comment.